Ask Your Question
0

Router cannot ping gateway

asked 2014-04-23 06:10:46 -0500

senyapsudah gravatar image

updated 2014-04-23 07:44:50 -0500

hi guys,

i'm currentlly running on icehouse in ubuntu 14.04. so far everything seems working except for neutron. i can see all agent are reporting to the controller. i'm able to create the router and attached it to the external network. however, i'm not able to ping my gateway. try to look for the issue inside the l3 agent logs and also neutron server log but cant find anything on it.

i can see all ports attached to the router is ACTIVE.

any suggestion how to troubleshoot on this?

edit retag flag offensive close merge delete

Comments

1

Seems like the issue is with my network interface, previously it was working fine when i was on 12.04. after upgrading to 14.04 seems like the interface cannot work. even when i set the ip address directly to the interface also not working. :(

senyapsudah gravatar imagesenyapsudah ( 2014-04-23 07:38:22 -0500 )edit

How do you upgrade from 12.04 to 14.04? Are you following any guide?

Antonio G. gravatar imageAntonio G. ( 2014-04-23 07:53:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-24 03:17:42 -0500

DanIzack gravatar image
Setup doc for IceHouse (RHEL/CentOS)  release says 

On  RHEL/Centos "Open vSwitch (OVS) plug-in Warning We suggest that you implement the Modular Layer 2 (ML2) plug-in on Icehouse until we completely test the traditional Open vSwitch (OVS) plug-in." 

 You are doing setup IceHouse on ubuntu 14.04, and expecting Neutron L3 Agent and OVS plugin to be in good shape. Your network interface was fine with IPv4.

Take a look at this Link, it may help to understand what is going on.

edit flag offensive delete link more

Comments

Hi Dan,

Thanks for the link. Actually it seems like the issue is on my igb driver for the interface. even when i uninstall neutron and set static ip to the interface, it still cant communicate with my external network. so revert back to 12.04 and its working fine now. :)

senyapsudah gravatar imagesenyapsudah ( 2014-04-25 07:06:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-23 06:10:46 -0500

Seen: 776 times

Last updated: Apr 24 '14