Ask Your Question
0

SLES havana nova-network network-create ERROR: HTTPConnectionPool(host='controller', port=8774): Request timed out.

asked 2014-04-22 05:10:43 -0500

MerM gravatar image

updated 2014-04-23 03:01:15 -0500

hi

I'm installing openstack havana on SLES11.3 following the http://docs.openstack.org/havana/install-guide/install/zypper/content/nova-network.html (Zypper Install Guide) = one controller node, one compute node, two NICs each (internal - external network) using nova-network (not neutron)

Everything works until the http://docs.openstack.org/havana/install-guide/install/zypper/content/nova-network.html (create-network) chapter.

nova-network create gets a time-out on the controller node:

$ nova network-create vmnet --fixed-range-v4=172.32.1.0/24 --bridge=br100 --multi-host=T
ERROR: HTTPConnectionPool(host='controller', port=8774): Request timed out. (timeout=600)

in nova.log only a connect to rabbitmq shows up:

  2014-04-18 16:50:14.692 10954 INFO nova.osapi_compute.wsgi.server [-] (10954) accepted ('192.168.212.116', 42336)

2014-04-18 16:50:15.276 10954 INFO nova.openstack.common.rpc.common [req-44e68ba5-8e2a-4c28-a297-00d8d3c42b80 63841c7a661a4e4d841f4de08304b279 626f583873914c2ebc7fcfa9d30a1468] Connected to AMQP server on controller:5672
2014-04-18 16:50:15.291 10954 INFO nova.openstack.common.rpc.common [req-44e68ba5-8e2a-4c28-a297-00d8d3c42b80 63841c7a661a4e4d841f4de08304b279 626f583873914c2ebc7fcfa9d30a1468] Connected to AMQP server on controller:5672

looks like a service is missing but i'm completely in the dark - tried to follow the guide a second time but ran into the same situation again.

any help would be greatly appreciated

TIA

Update 1:

found connection refused error in rabbitmq log:

=ERROR REPORT==== 22-Apr-2014::12:24:51 ===
closing AMQP connection <0.10035.2> (192.168.212.116:34258 -> 192.168.212.116:5672):
{handshake_error,starting,0,
                 {amqp_error,access_refused,
                             "AMQPLAIN login refused: user 'guest' - invalid credentials",
                             'connection.start_ok'}}

nova.conf:

rabbit_host=controller
rabbit_password=guest

password for user guest is set to 'guest' via rabbitmqctl

Update 2:

Logs and Debug ouput

http://paste.openstack.org/show/76616/ (nova --debug network-create output)

http://paste.openstack.org/show/76617/ (/var/log/nova/nova.log)

http://paste.openstack.org/show/76734/ (nova.conf of compute nodes)

http://paste.openstack.org/show/76735/ (nova.conf of controller node)

edit retag flag offensive close merge delete

Comments

Try putting debug and verbose mode on in your nova.conf file. Then restart nova services and try again network-create command, pastebin your new log files ( http://paste.openstack.org/ ).

Antonio G. gravatar imageAntonio G. ( 2014-04-22 05:26:43 -0500 )edit

Do you see any ERROR related to AMQP in your nova log files?

Antonio G. gravatar imageAntonio G. ( 2014-04-22 05:44:36 -0500 )edit

thx antonio.

http://paste.openstack.org/show/76616/ (nova --debug network-create output)

http://paste.openstack.org/show/76617/ (/var/log/nova/nova.log)

sorry not allowed to post links yet.

and no amqp errors in grep -i AMQP /var/log/nova/nova.log|grep -Ev "INFO|DEBUG"

MerM gravatar imageMerM ( 2014-04-22 05:45:47 -0500 )edit

Which is the state of your openstack-nova-network service? Is it running? Do you have a log file for it?

service openstack-nova-network status
Antonio G. gravatar imageAntonio G. ( 2014-04-22 06:54:16 -0500 )edit

openstack-nova-network service is running on both compute nodes but not on the controller (as stated in the docs). no specific nova-network logfile was written.

MerM gravatar imageMerM ( 2014-04-22 08:16:04 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-17 15:58:31 -0500

rushi gravatar image

i have the same problem. can someone proivde a tip or solution on how to overcome this problem . BR Rushi.

edit flag offensive delete link more

Comments

hi this is quite urgent, can openstack development provide a solution .

BR. Rushi.

rushi gravatar imagerushi ( 2014-12-17 16:09:09 -0500 )edit

Do you have the same error in rabbitmq.log? Check your AMQP credentials in your nova config files...

Antonio G. gravatar imageAntonio G. ( 2014-12-18 03:08:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-22 05:10:43 -0500

Seen: 1,471 times

Last updated: Apr 23 '14