Ask Your Question
0

lbaas configuration: vip - connection refused

asked 2014-04-22 04:13:34 -0500

vladber gravatar image

Hi ,

I'm testing the lbaas in Havana . have the following settings :

subnet 30.30.30.0/24 web1 - 30.30.30.10 web2 - 30.30.30.12 vip - 30.30.30.254

pool lb with web 1 and 2 as members. ping to vip works but wget to vip gives - connection refused error like:

ip netns exec qrouter-46e8dc37-46df-4a2f-bcd5-f71da5ab0e5e wget -O - http://30.30.30.254 --2014-04-22 12:12:57-- http://30.30.30.254/ Connecting to 30.30.30.254:80... failed: Connection refused.

/usr/share/neutron/neutron-dist.conf: service_provider = LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

/etc/neutron/neutron.conf service_plugins = neutron.services.loadbalancer.plugin.LoadBalancerPlugin

/etc/neutron/lbaas_agent.ini: interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver device_driver = neutron.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver

What can be a problem ?

/Vlad

launched 2 VMs with a simple web running , created new pool , added

edit retag flag offensive close merge delete

Comments

If you wget the two web server directly do you reach the web pages?

Do you have any ERROR in your neutron log files? (if so pastebin them)

Antonio G. gravatar imageAntonio G. ( 2014-04-22 05:37:13 -0500 )edit
1

Thanks ,

I think I found what caused the problem .We are using the RH openstack edition .I inspected the /var/log/neutron/lbaas-agent.log and noticed a lot of errors like:

parsing [/var/lib/neutron/lbaas/21ec4386-4dad-4479-9de7-56c50dc83c94/conf:4] : cannot find group id for 'nogroup' (0:Success)\n[ALERT] 111/133154 (25963) : Error(s) found in configuration file : /var/lib/neutron/lbaas/21ec4386-4dad-4479-9de7-56c50dc83c94/conf\n[ALERT] 111/133154 (25963) : Fatal errors found in configuration.\n"

And it turned out that nogroup was not exist .So , I added it manually , enabled it in lbaas_agent.ini ( user_group = nogroup ) and restarted relevant services .Now VIP has port 80 opened .

Will contact RH on possible bug .

/Vlad

vladber gravatar imagevladber ( 2014-04-22 05:58:50 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-23 16:23:39 -0500

Naveen Chandra gravatar image

I have the same problem in RHEL 6.5 I have changed lbaas_agent.ini user_group = group is commented, I uncommented. I still get the same error in the logs. Anything else needs to be done. Could you please paste your lbaas_agent.ini file

edit flag offensive delete link more

Comments

I think the correct value should be:

user_group = nogroup
Antonio G. gravatar imageAntonio G. ( 2014-05-26 04:04:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-22 04:13:34 -0500

Seen: 884 times

Last updated: May 23 '14