Ask Your Question
0

swift-dispersion-populate failed

asked 2014-04-21 15:10:55 -0500

Eslam El Husseiny gravatar image

Hi everyone,

I was trying to configure swift dispersion component on my swift havana setup, but unfortunatelly I got this error

swiftclient.exceptions.ClientException: Auth GET failed: http://172.16.0.200:5000/v2.0 200 OK

my /etc/swift/dispersion.conf file https://gist.github.com/anonymous/11154871 (https://gist.github.com/anonymous/111...) my swift setup is configured with keystone setup and working fine.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-06-12 15:39:33 -0500

Rakesh Patnaik gravatar image

updated 2014-06-12 15:40:27 -0500

I had the same error show up. I fixed by adding the auth_version property to dispersion.conf. My /etc/swift/dispersion.conf looks as follows:

[dispersion]

auth_url = http://172.16.0.200:5000/v2.0/

auth_user = cookbook:demo

auth_key = openstack

auth_version = 2.0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-21 15:10:55 -0500

Seen: 418 times

Last updated: Jun 12 '14