Ask Your Question
0

Icehouse initial setup, error creating admin in keystone

asked 2014-04-21 13:56:14 -0500

dro gravatar image

updated 2014-04-24 07:03:07 -0500

following the documentation and running:

keystone user-create --name=admin --pass=myadminpasss --email=myadmin@myemail.com

An unexpected error prevented the server from fulfilling your request. (HTTP 500)


i see this in the keystone.log

also, this is my db config in keystone.conf

[database]
connection = mysql://keystone:keystonespasswd@controller/keystone   # is this correct?
edit retag flag offensive close merge delete

Comments

Did you follow all steps on the keystone installation guide (specifically DB creation, step 4 and DB init step 5)?

http://docs.openstack.org/icehouse/in...

The DB config line is correct if you chosen 'keystonespasswd' as 'KEYSTONE_DBPASS' in the previosly referenced guide.

Antonio G. gravatar imageAntonio G. ( 2014-04-21 14:08:59 -0500 )edit

the password is different, i put it in as generic. I followed these steps, per openstack RHEL/Centos installation

  1. yum install openstack-keystone python-keystoneclient

  2. # openstack-config --set /etc/keystone/keystone.conf \ database connection mysql://keystone:KEYSTONE_DBPASS@controller/ keystone ( replacing, keystone_dbpass, with mh own pass)

  3. created mysql and granted privileges, per the doc, cut and paste pretty much, minus password changes

mysql -u root -p mysql> CREATE DATABASE keystone; mysql> GRANT ALL PRIVILEGES ON keystone.* TO 'keystone'@'localhost' \ IDENTIFIED BY 'KEYSTONE_DBPASS'; mysql> GRANT ALL PRIVILEGES ON keystone.* TO 'keystone'@'%' \ IDENTIFIED BY 'KEYSTONE_DBPASS'; mysql> exit

4.

su -s /bin/sh -c "keystone-manage db_sync" keystone

  1. admin token # ADMIN_TOKEN=$(openssl rand -hex 10)

    echo $AD

  2. pki tokens

# keystone-manage pki_setup --keystone-user keystone --keystone-group keystone

chown -R keystone:keystone /etc/keystone/ssl # chmod -R o-rwx /etc/keystone/

  • started, openstack-keystone
dro gravatar imagedro ( 2014-04-21 14:14:36 -0500 )edit

ok, be sure to do not have spaces in this command (after controller/):

# openstack-config --set /etc/keystone/keystone.conf \ database connection mysql://keystone:KEYSTONE_DBPASS@controller/keystone

check it in keystone.conf file

Antonio G. gravatar imageAntonio G. ( 2014-04-21 14:21:32 -0500 )edit
1

the issue was that my server name was not controller, since I'm doing this in a VM, i rolled back the image and renamed it. I no longer get that error, thank you

dro gravatar imagedro ( 2014-04-21 17:15:55 -0500 )edit

For me the problem was a few steps back in the installation procedure - Keystone database configuraiton file setup.

for me the fix was to change the line in /etc/keystone/keystone.com from: connection = mysql://keystone:mypass@controller/keystone to: connection = mysql://keystone:mypass@locahost/keystone

I've tried to debug why the name controller is not usefull in my machine, it can be pinged. It is not the HOSTNAME - but when I tried to change my Linux HOSTNAME to controller this didn't seem to fix it and just substituting localhost did. As I understand it this database and keystone instance will only be acessed form this 1 node so this is OK for me.

I was then able to go onto step 5 and create the Keystone database successfully (which is a point I must have either skipped or failed before).

jame gravatar imagejame ( 2014-05-18 12:07:11 -0500 )edit

2 answers

Sort by » oldest newest most voted
1

answered 2014-04-24 02:37:59 -0500

DanIzack gravatar image

updated 2014-04-24 06:59:42 -0500

I've seen http://docs.openstack.org/icehouse/in...

Command recommended

$ keystone user-create --name=admin --pass=ADMIN_PASS --email=ADMIN_EMAIL

Even though correct syntax could be ( it worked so in Havana)

$ keystone user-create --name  admin --pass adminpassword
edit flag offensive delete link more
0

answered 2014-04-21 14:52:21 -0500

dro gravatar image

should my server host name be controller? or can it be something else. I have its ip address specified in /etc/hosts, also , now I'm getting this error

keystone user-create --name=admin --pass=adminpass --email=admin@myemail.com Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL]

edit flag offensive delete link more

Comments

Yes, your server host name should be controller (of course you could change it, but change the connection line accordingly). You could also put your IP address although it is suggested to put the server name.

See networking part of installation guide. http://docs.openstack.org/icehouse/in...

Antonio G. gravatar imageAntonio G. ( 2014-04-21 15:08:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-21 13:56:14 -0500

Seen: 1,856 times

Last updated: Apr 24 '14