Six version conflict error....has updated six to 1.61, but it always say it need to be <1.4.1 [closed]

asked 2014-04-21 00:23:56 -0500

Barry gravatar image

hi, I'm installing havana on Ubuntu 12.04 according to guidelines from official site. but i notice from nova-api log when i boot a image...like the below

2014-04-21 12:17:40.633 4264 ERROR stevedore.extension [-] Could not load 'file': (six 1.6.1 (/usr/local/lib/python2.7/dist-packages/six-1.6.1-py2.7.egg), Requirement.parse('six<1.4.1')) 2014-04-21 12:17:40.633 4264 ERROR stevedore.extension [-] (six 1.6.1 (/usr/local/lib/python2.7/dist-packages/six-1.6.1-py2.7.egg), Requirement.parse('six<1.4.1')) 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension Traceback (most recent call last): 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/stevedore/extension.py", line 89, in _load_plugins 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension invoke_kwds, 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/stevedore/extension.py", line 101, in _load_one_plugin 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension plugin = ep.load() 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1988, in load 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension if require: self.require(env, installer) 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2001, in require 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension working_set.resolve(self.dist.requires(self.extras),env,installer)) 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 588, in resolve 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension raise VersionConflict(dist,req) # XXX put more info here 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension VersionConflict: (six 1.6.1 (/usr/local/lib/python2.7/dist-packages/six-1.6.1-py2.7.egg), Requirement.parse('six<1.4.1')) 2014-04-21 12:17:40.633 4264 TRACE stevedore.extension

I'm so confused, anyone have ideas about this....Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2014-04-21 04:25:37.762006

Comments

Same error here: https://ask.openstack.org/en/question... vote the question up instead or opening a new one

smaffulli gravatar imagesmaffulli ( 2014-04-21 04:25:29 -0500 )edit