Ask Your Question
0

unable to establish conncetion to http://controller:35357/v2.0/users [closed]

asked 2014-04-17 12:30:01 -0500

anonymous user

Anonymous

I have followed it at the letter and everything ok but at this moment. But when i try to create a user it says the problem: Unable to establish connection to http://controller35357/v2.0/user . I amt et chapter 3 part 3.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-04-18 08:53:14.575159

Comments

What guide are you following to set this up? Where are you running these commands? What commands? Please provide more information.

SamYaple gravatar imageSamYaple ( 2014-04-17 13:08:18 -0500 )edit
  1. export OS_SERVICE_TOKEN=xxxxxx
  2. export OS_SERVICE_ENDPOINT=http://controller:35357/v2.0

then i try creating an admin at the keystone, but i receive the message.

e.hasani gravatar imagee.hasani ( 2014-04-17 17:40:26 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-04-17 19:51:06 -0500

9lives gravatar image

Could you turn on the debug option when you run keystone client? eg: keystone --debug user-list This will give us more detailed info for finding the root cause and make sure your OS_SERVICE_TOKEN is exactly the same as what you defined in /etc/keystone/keystone.conf.

BTW: Are you behind any proxy server when you issue the keystone command, is so just export the no_proxy environment variables to see if it works.

Hope that helps!

Vic

edit flag offensive delete link more

Comments

i have checked inside the keystone.conf if it got the admin token end it have it as it is written in the manual. And i don't have a proxy server i just have only one physical server, in my office. I think i will do the procedure from the beginning maybe i have don something wrong. BTW: I have checked only if the admin token was the same as the token i have generated, nothing else

e.hasani gravatar imagee.hasani ( 2014-04-18 01:39:25 -0500 )edit

Are you using icehouse or Havana and which token provider are you using (UUID or PKI) if you are using PKI just referring this guide http://docs.openstack.org/admin-guide... for PKI trouble shooting. Hope that helps! Vic

9lives gravatar image9lives ( 2014-04-18 02:04:37 -0500 )edit
1

u r right i did not notice the openstack have changed the manual and i was following the procedure for havana. now it works. thnx

e.hasani gravatar imagee.hasani ( 2014-04-18 04:48:37 -0500 )edit
2

answered 2014-04-17 14:49:38 -0500

sroot gravatar image

I can see you're missing a colon ( : ) http://controller35357/v2.0/user should be http://controller:35357/v2.0/user

After that, is your host called 'controller'? I found 'localhost' worked for my initial tests. I'm assuming an FQDN or IP address will work once I reach a point of trying a setup with multiple servers.

edit flag offensive delete link more

Comments

yes i have added dhe (:). yes my host is called controller. I have tried localhost but i receive another message: Invalid OpenStack Identity credentials. It is very strange i have fallowed all the steps very perfectly with no errors, it worked everything but this one.

e.hasani gravatar imagee.hasani ( 2014-04-17 17:37:35 -0500 )edit
0

answered 2014-04-18 04:47:22 -0500

e.hasani gravatar image

I have done all the procedure from the begining and now it works. Thanx to every one for the help

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-04-17 12:30:01 -0500

Seen: 3,531 times

Last updated: Apr 18 '14