Devstack installation fails with error Requirement.parse('six<1.4.0'))

asked 2014-04-17 05:05:03 -0500

dlzhangster gravatar image

updated 2014-04-18 09:37:02 -0500

smaffulli gravatar image

I am trying to install devstack on one of my machines. The current version goes well with one machine, however, when I am trying to install on a different machine, I got the following problem:

+ create_keystone_accounts
2014-04-17 17:17:03.361 | ++ openstack project create admin
2014-04-17 17:17:03.362 | ++ grep ' id '
2014-04-17 17:17:03.364 | ++ get_field 2
2014-04-17 17:17:03.365 | ++ read data
2014-04-17 17:17:03.818 | ERROR: openstackclient.shell Exception raised: (six 1.6.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('six<1.4.0'))
2014-04-17 17:17:03.836 | + ADMIN_TENANT=
2014-04-17 17:17:03.839 | ++ openstack user create admin --project '' --email admin@example.com --password mypassword
2014-04-17 17:17:03.840 | ++ grep ' id '
2014-04-17 17:17:03.842 | ++ get_field 2
2014-04-17 17:17:03.844 | ++ read data
2014-04-17 17:17:04.222 | ERROR: openstackclient.shell Exception raised: (six 1.6.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('six<1.4.0'))
2014-04-17 17:17:04.241 | + ADMIN_USER=
2014-04-17 17:17:04.245 | ++ openstack role create admin
2014-04-17 17:17:04.247 | ++ grep ' id '
2014-04-17 17:17:04.248 | ++ get_field 2
2014-04-17 17:17:04.250 | ++ read data
2014-04-17 17:17:04.625 | ERROR: openstackclient.shell Exception raised: (six 1.6.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('six<1.4.0'))
2014-04-17 17:17:04.643 | + ADMIN_ROLE=
2014-04-17 17:17:04.646 | + openstack role add --project --user
2014-04-17 17:17:05.033 | ERROR: openstackclient.shell Exception raised: (six 1.6.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('six<1.4.0'))
2014-04-17 17:17:05.051 | + exit_trap
stack@dhpc10:~/devstack$ 2014-04-17 17:17:05.053 | + local r=1
2014-04-17 17:17:05.056 | ++ jobs -p
2014-04-17 17:17:05.058 | + jobs=
2014-04-17 17:17:05.060 | + [[ -n '' ]]
2014-04-17 17:17:05.062 | + exit 1

I deleted directory 'devstack', '/opt/stack' and '/usr/local/lib/python2.7/dist-packages/six*', and reinstalled all of them, still got the same problem. Not sure whey this would happen.

edit retag flag offensive close merge delete

Comments

Looks like a dependency is not being being satisfied. Edit your question to specify the difference between the two machines you're installing devstack on

smaffulli gravatar imagesmaffulli ( 2014-04-18 09:39:57 -0500 )edit

I get the same on a production deployment of OpenStack with the following trace: http://hastebin.com/esudubemay.rb

This is in /etc/nova/nova-scheduler.log

Tim gravatar imageTim ( 2014-05-12 17:57:10 -0500 )edit

I am having a similar error "Requirements.parse(oslo.utils>=0.3.0)". Were you able to get past your error and how did you resolve it?

vishwanathj gravatar imagevishwanathj ( 2014-09-26 10:21:40 -0500 )edit

I had a similar error of oslo.i18n conflict. Is there any update of this thread?

kingbird gravatar imagekingbird ( 2015-12-28 07:11:43 -0500 )edit