Ask Your Question
2

Devstack ERROR neutron.openstack.common.rpc.common [-] AMQP server on ip:5672 is unreachable: [Errno 111] ECONNREFUSED.

asked 2014-04-17 02:19:41 -0500

SidBali gravatar image

updated 2014-06-08 10:53:52 -0500

SamYaple gravatar image

I am trying to install RYU using Devstack, but I am not able to stack the openstack controller facing the error ERROR neutron.openstack.common.rpc.common [-] AMQP server on ip:5672 is unreachable: [Errno 111] ECONNREFUSED.

I have two nodes a controller and compute node in my installation and I m referencing from https://github.com/osrg/ryu/wiki/RYU-...

Error Encountered:-

[fedora@controller devstack]$ screen -x stack
2014-04-17 09:06:31.615 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:06:31.627 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:07:01.650 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:07:01.668 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:07:31.695 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:07:31.740 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:08:01.772 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:08:01.784 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:08:31.808 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:08:31.831 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:09:01.857 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:09:01.867 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:09:31.891 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:09:31.900 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:10:01.926 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:10:01.943 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.57.103:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.
2014-04-17 09:10:31.965 INFO neutron.openstack.common.rpc.common [-] Reconnecting to AMQP server on 192.168.57.103:5672
2014-04-17 09:10:31.981 ERROR neutron.openstack.common.rpc ...
(more)
edit retag flag offensive close merge delete

Comments

Translate to Ubuntu following test ( I am on Fedora 20 Controller)

$ service qpidd status -l
Redirecting to /bin/systemctl status  -l qpidd.service
qpidd.service - An AMQP message broker daemon.
   Loaded: loaded (/usr/lib/systemd/system/qpidd.service; enabled)
   Active: active (running) since Thu 2014-04-17 08:19:50 MSK; 3h 42min ago
     Docs: man:qpidd(1)
           http://qpid.apache.org/
 Main PID: 2367 (qpidd)
   CGroup: /system.slice/qpidd.service
           └─2367 /usr/sbin/qpidd --config /etc/qpid/qpidd.conf
. . . . . .

Apr 17 08:19:52 dallas1.localdomain qpidd[2367]: 2014-04-17 08:19:52 [Broker] notice SASL disabled: No Authentication Performed
Apr 17 08:19:52 dallas1.localdomain qpidd[2367]: 2014-04-17 08:19:52 [Network] notice Listening on TCP/TCP6 port 5672
Apr 17 08:19:52 dallas1.localdomain qpidd[2367]: 2014-04-17 08:19:52 [Broker] notice Broker running

$ netstat -lntp | grep qpidd
tcp        0      0 0.0.0.0:5672            0.0 ...
(more)
dbaxps gravatar imagedbaxps ( 2014-04-17 03:05:48 -0500 )edit

qpidd Daemon on F20,CentOS 6.5 works like AMQP Setver. I guess on Ubuntu same daemon has another name. You need daemon's name check it's status && port at which it's supposed to listen

dbaxps gravatar imagedbaxps ( 2014-04-17 03:12:19 -0500 )edit

Do you still have this issue?

SamYaple gravatar imageSamYaple ( 2014-06-08 10:54:22 -0500 )edit

3 answers

Sort by » oldest newest most voted
3

answered 2014-04-17 04:49:40 -0500

dbaxps gravatar image

updated 2014-04-18 04:24:28 -0500

Would try on Ubuntu :-
Per AMQP server on localhost:5672 is unreachable
Change the RabbitMQ guest password: sudo rabbitmqctl change_password guest password
Restart RabbitMQ service: sudo service rabbitmq restart
If it won't work
Change the RabbitMQ guest password: $ sudo rabbitmqctl change-password guest guest
Restart RabbitMQ service: sudo service rabbitmq restart
[Errno 111] ECONNREFUSED means usualy firewall (IPv4 iptables firewall) issue
So , check $ iptables-save | grep 5672 and make sure port is open via iptables firewall
Then check
$ service rabbitmq status
$ netstat -lntp | grep rabbitmq
which supposed provide you pid. Say xxxx
$ ps -ef | grep xxxx

edit flag offensive delete link more
2

answered 2014-05-04 20:29:07 -0500

6543217890meh gravatar image

I had this issue and found that the problem was because neutron was not able to communicate with rabbitmq. To see if this is your problem you can try the following snippet of code:

Script started, file is typescript [ -r /etc/default/neutron-server ] && . /etc/default/neutron-server [ -r "$NEUTRON_PLUGIN_CONFIG" ] && CONF_ARG="--config-file $NEUTRON_PLUGIN_CONFIG" exec start-stop-daemon --start --chuid neutron --exec /usr/bin/neutron-server -- \ --config-file /etc/neutron/neutron.conf \ --log-file /var/log/neutron/server.log $CONF_ARG end script

(you can find this at the end of a file found in /etc/init/neutron-server.conf)

When I ran this it showed me errors I had in my config files and after I fixed them it showed the following: 2014-05-03 17:19:33.123 17996 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.0.143:5672 is unreachable: Socket closed. Trying again in 1 seconds. 2014-05-03 17:19:37.136 17996 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.0.143:5672 is unreachable: Socket closed. Trying again in 3 seconds. 2014-05-03 17:19:43.149 17996 ERROR neutron.openstack.common.rpc.common [-] AMQP server on 192.168.0.143:5672 is unreachable: Socket closed. Trying again in 5 seconds.

I then ran netstat to see what port rabbitmq had opened. Rabbitmq had opened the port, but tied it to "localhost" not my ip address, which I would have thought. So to fix neutron not being able to find rabbitmq. I changed the following lines in my config files:

rabbit_host = localhost

Then I changed my /etc/hosts file to reflect the following:

"my Ip address" localhost ------instead of the 127.0.0.1 localhost that was default in my file.

After I did all of the nuetron and nova now actually started talking to rabbitmq and I stopped getting the [Errno 111] ECONNREFUSED error. Hope this helps.

edit flag offensive delete link more
1

answered 2014-06-07 15:50:31 -0500

jame gravatar image

Pretty good steps for debugging. Thanks. I learned a lot by following them. THe fix though was:

sudo rabbitmqctl change_password guest guest

No restart required.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-17 02:19:41 -0500

Seen: 18,520 times

Last updated: Jun 08 '14