Ask Your Question

Wrong Response code 302 when running get token

asked 2014-04-16 14:33:22 -0600 gravatar image

updated 2014-04-18 10:12:02 -0600

smaffulli gravatar image

I am getting following response with status code 302 when running get token on a openstack using REST

Request: POST
Request Headers: {'Content-Type': 'application/json', 'Accept': 'application/json'}
Request Body: {"auth": {"scope": {"project": {"domain": {"name": "Default"}, "name": "default"}}, "identity": {"password": {"user": {"domain": {"name": "Default"}, "password": "admin", "name": "admin"}}, "methods": ["password"]}}}
Response Status: 302
 Response Headers: {'content-length': '319', 'location': '', 'date': 'Wed, 16 Apr 2014 15:33:50 GMT', 'content-type': 'text/html; charset=iso-8859-1', 'connection': 'close', 'server': 'Apache/2.2.15 (Red Hat)'}
 Response Body: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<title>302 Found</title>

The same is working good from Chrome REST Addon. can somebody help me out on when can we expect response status as 302

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-04-18 11:55:07 -0600

 Is the url  correct?  Normally it will be  unless your installation has changed the context path
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-04-16 14:33:22 -0600

Seen: 249 times

Last updated: Apr 18 '14