Ask Your Question
0

Error: Service s-proxy is not running - OpenStack installation

asked 2014-04-11 16:27:11 -0500

mani619cash gravatar image

I am trying to install OpenStack with DevStack

Once I installed successfully but Swift is not enabled by default

So I tried to unstack.sh and then stack.sh by using this local.conf but I am getting this error when Swift is enabled.

++ ls /opt/stack/status/stack/s-proxy.failure
+ failures=/opt/stack/status/stack/s-proxy.failure
+ for service in '$failures'
++ basename /opt/stack/status/stack/s-proxy.failure
+ service=s-proxy.failure
+ service=s-proxy
+ echo 'Error: Service s-proxy is not running'
Error: Service s-proxy is not running
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-04-15 01:03:49 -0500

fifieldt gravatar image

updated 2014-04-15 01:04:07 -0500

Ensure you have

SWIFT_REPLICAS=1

SWIFT_HASH=01241232342343252532

ENABLED_SERVICES+=,s-proxy,s-object,s-container,s-account

in your local.conf

edit flag offensive delete link more

Comments

I have but still same error

mani619cash gravatar imagemani619cash ( 2014-04-15 01:51:38 -0500 )edit
clayg gravatar imageclayg ( 2014-04-16 18:14:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-11 16:27:11 -0500

Seen: 374 times

Last updated: Apr 15 '14