Ask Your Question
0

packstack (centos 6.5) issue with Havana

asked 2014-04-11 14:39:46 -0500

dubi gravatar image

updated 2014-04-11 15:11:17 -0500

I am running: packstack --allinone which worked to completion on fedora 19.

But now I am running it for CENTOS 6.5 and getting the following error (after doing ok mysql and qpid stages):

Applying 9.148.26.136_keystone.pp Applying 9.148.26.136_glance.pp

Applying 9.148.26.136_cinder.pp [ ERROR ]

ERROR : Error appeared during Puppet run: 9.148.26.136_keystone.pp

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: python-dogpile- cache-0 .5.0-1.el6.noarch (openstack-havana)

You will find full trace in log /var/tmp/packstack/20140411-221426-2SCYuT/manifests /9.148.26.136_keystone.pp.log

Please check log file /var/tmp/packstack/20140411-221426-2SCYuT/openstack-setup.log for more information

In the file /var/tmp/packstack/20140411-221426-2SCYuT/manifests /9.148.26.136_keystone.pp.log I find the following:

^[[1;31mError: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-keystone' returned 1: Error: Package: python-dogpile-cache-0.5.0-1.el6.noarch (openstack-havana)

       Requires: python-dogpile-core >= 0.4.1

Error: Package: python-migrate-0.7.2-8.el6.noarch (openstack-havana)

       Requires: python-sqlalchemy0.7

Error: Package: 1:python-keystoneclient-0.4.1-4.el6.noarch (openstack-havana)

       Requires: python-requests >= 0.8.8

Error: Package: 1:python-keystoneclient-0.4.1-4.el6.noarch (openstack-havana)

       Requires: python-argparse

Error: Package: python-keystone-2013.2.3-2.el6.noarch (openstack-havana)

       Requires: python-sqlalchemy0.7

Error: Package: python-keystone-2013.2.3-2.el6.noarch (openstack-havana)

       Requires: python-eventlet

Error: Package: python-keystone-2013.2.3-2.el6.noarch (openstack-havana)

       Requires: python-paste-deploy1.5

Error: Package: 1:python-keystoneclient-0.4.1-4.el6.noarch (openstack-havana)

       Requires: python-six

Error: Package: 1:python-keystoneclient-0.4.1-4.el6.noarch (openstack-havana)

       Requires: python-keyring

Error: Package: python-keystone-2013.2.3-2.el6.noarch (openstack-havana)

       Requires: python-passlib

Error: Package: 1:python-keystoneclient-0.4.1-4.el6.noarch (openstack-havana)

       Requires: python-prettytable

Error: Package: python-keystone-2013.2.3-2.el6.noarch (openstack-havana)

       Requires: python-six

Error: Package: python-oauth2-1.5.211-5.el6.noarch (openstack-havana)

       Requires: python-httplib2

Error: Package: python-keystone-2013.2.3-2.el6.noarch (openstack-havana)

       Requires: python-routes1.12

Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana)

       Requires: python-argparse

Error: Package: 1:python-oslo-config-1.2.1-1.el6.noarch (openstack-havana)

       Requires: python-six

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest


if I try : /usr/bin/yum -d 0 -e 0 -y --skip-broken install openstack-keystone

I get:

Packages skipped because of dependency problems:

PyPAM-0.5.0-12.el6.x86_64 from base

openstack-keystone-2013.2.3-2.el6.noarch from openstack-havana

python-babel-0.9.4-5.1.el6.noarch from base

python-dogpile-cache-0.5.0-1.el6.noarch from openstack-havana

python-iso8601-0.1.8-1.el6.noarch from openstack-havana

python-keystone-2013.2.3-2.el6.noarch from openstack-havana

1:python-keystoneclient-0.4.1-4.el6.noarch from openstack-havana

python-memcached-1.53-1.el6.noarch from openstack-havana

python-migrate-0.7.2-8.el6.noarch from openstack-havana

python-oauth2-1.5.211-5.el6.noarch from openstack-havana

1:python-oslo-config-1.2.1-1.el6.noarch from openstack-havana

python-simplejson-2.0.9-3.1.el6.x86_64 from base

python-tempita-0.4-2.el6.noarch from base

python-webob-1.2.3-4.el6.noarch from openstack-havana

But then keystone is not installed . Unacceptable !

Any idea how to fix ? Thx in advance

edit retag flag offensive close merge delete

Comments

CentOS has older python 2.6x, better to upgrade to 2.7.6 or more.

  1. List item
SGPJ gravatar imageSGPJ ( 2014-04-11 15:02:14 -0500 )edit

This isn't required, at this time OpenStack still works on Python 2.6 (even Icehouse), there are in fact gate jobs that enforce this.

sgordon gravatar imagesgordon ( 2014-04-13 14:31:34 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-04-12 08:34:33 -0500

dubi gravatar image

updated 2014-04-12 09:00:11 -0500

Solved by CONFIG_USE_EPEL=y in the packstack config file and using the following 2 installed packets:

yum install -y http://rdo.fedorapeople.org/openstack...

(havana-7 version used)

yum install http://dl.fedoraproject.org/pub/epel/...

yum -y update

reboot

I did not replace the default installed python 2.6.6

set Selinux to disabled state

then: packstack --allinone

edit flag offensive delete link more
0

answered 2014-04-11 14:59:32 -0500

dbaxps gravatar image

updated 2014-04-12 02:03:24 -0500

View Centos 6.5 - Havana - InstanceTypeDiskTooSmall
Quote

I am completely new to this, so please forgive my ignorance. I have installed Havana on Centos 6.5 (rdo-release-havana-7.noarch.rpm) with packstack --allinone on a new machine (after format, centos install, yum update -y) 
The RPM been used for install was rdo-release-havana-7.noarch.rpm

Then no serious trouble (04/05/2014)
Download link What I did :-

 yum install http://rdo.fedorapeople.org/openstack-havana/rdo-release-havana.rpm
Loaded plugins: langpacks, priorities, refresh-packagekit
rdo-release-havana.rpm                                                                      |  11 kB  00:00:00     
Examining /var/tmp/yum-root-IeGr31/rdo-release-havana.rpm: rdo-release-havana-7.noarch
Marking /var/tmp/yum-root-IeGr31/rdo-release-havana.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package rdo-release.noarch 0:havana-7 will be installed
--> Finished Dependency Resolution
updates/20/x86_64/metalink                                                                  |  28 kB  00:00:00     

Dependencies Resolved

===================================================================================================================
 Package                    Arch                  Version                 Repository                          Size
===================================================================================================================
Installing:
 rdo-release                noarch                havana-7                /rdo-release-havana                8.7 k

Transaction Summary
===================================================================================================================
Install  1 Package

Total size: 8.7 k
Installed size: 8.7 k
Is this ok [y/d/N]: N
edit flag offensive delete link more

Comments

dbaxps gravatar imagedbaxps ( 2014-04-11 16:17:24 -0500 )edit

I am the one who asked the Q (dubi)

  1. This is not an EPEL problems . seems a python 2.6 problem (too old)

    so I am asking : if it works for fedora 19 why does RDO claim packstack works with CentOS ? or maybe RDO supports only RH6 and that distro have python 2.7 or higher. Why CentOs does not upgrade its python ?

  2. if I upgrade to python2.7 then (web search and see for the procedure) python2.7 will break yum of
    CentOS . The procedures advocate to install python2.7 side by side with existing 2.6.x So I have to have yum work with 2.6 while the package compile (or whatever) needs 2.7 How do they live/act together ? or I miss something . (see the failing comand above : /usr/bin/yum -d 0 -e 0 -y install openstack-keystone)

dubi gravatar imagedubi ( 2014-04-11 16:31:43 -0500 )edit
  1. if I am correct about 2. then it is a paradox Is yum code based on python ? if so is it possible to upgrade it too for CentOS ( which means CentOS is absolutely not fit for Packstack )
dubi gravatar imagedubi ( 2014-04-11 17:25:45 -0500 )edit
  1. In any case yum version at CentOS is also older than that at fedora 19 and probably won't work with python 2.7.6
dubi gravatar imagedubi ( 2014-04-11 17:30:16 -0500 )edit

This RDO Hangout: Multinode OpenStack with Packstack (February 27, 2014) was done on 02/27/2014 with CentOS 6.5
I would try to analyze Answer file and/or file bug to Bugzilla (this is all-in-one, e.g. just Proof of Concept)
I would also try:-

Setup EPEL manually and then run :-
$ sudo  yum install -y http://rdo.fedorapeople.org/rdo-release.rpm
$ sudo  yum -y update

Before running packstack View also trying to install RDO on centos 6.5, fails installing dashboard components as of 04/02/2014.
I believed things had changed since December 2013.
As appears they didn't , view Packstack on CentOs on the same page. Dubi also had me to spend this day (04/12) in front of monitor ;).He stated that did install on F19. SELINUX should be in permissive state on F19 as well, but I refreshed my memories about CentOS 6.5. Really ...

(more)

dbaxps gravatar imagedbaxps ( 2014-04-11 23:22:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-11 14:39:46 -0500

Seen: 3,078 times

Last updated: Apr 12 '14