Ask Your Question
1

VM gets no IP address assigned, cannot ping

asked 2014-04-11 11:59:29 -0500

SidBali gravatar image

updated 2014-04-18 09:31:52 -0500

smaffulli gravatar image

have IP address assigned to the VM, but I am not able to ping the VM form the DHCP Agent and Router namespace for that particular subnet. Moreover looking at the VM logs no IP address is getting assigned to it.

I am attaching the logs for VM generation.

[    0.000000] Initializing cgroup subsys cpuset
[    0.000000] Initializing cgroup subsys cpu
[    0.000000] Linux version 3.2.0-37-virtual (buildd@allspice) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #58-Ubuntu SMP Thu Jan 24 15:48:03 UTC 2013 (Ubuntu 3.2.0-37.58-virtual 3.2.35)
[    0.000000] Command line: LABEL=cirros-rootfs ro console=tty1 console=ttyS0
[    0.000000] KERNEL supported cpus:
[    0.000000]   Intel GenuineIntel
[    0.000000]   AMD AuthenticAMD
[    0.000000]   Centaur CentaurHauls
[    0.000000] Disabled fast string operations
[    0.000000] BIOS-provided physical RAM map:
[    0.000000]  BIOS-e820: 0000000000000000 - 000000000009dc00 (usable)
[    0.000000]  BIOS-e820: 000000000009dc00 - 00000000000a0000 (reserved)
[    0.000000]  BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
[    0.000000]  BIOS-e820: 0000000000100000 - 000000001fffd000 (usable)
[    0.000000]  BIOS-e820: 000000001fffd000 - 0000000020000000 (reserved)
[    0.000000]  BIOS-e820: 00000000fffbc000 - 0000000100000000 (reserved)
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] DMI 2.4 present.
[    0.000000] No AGP bridge found
[    0.000000] last_pfn = 0x1fffd max_arch_pfn = 0x400000000
[    0.000000] x86 PAT enabled: cpu 0, old 0x70106, new 0x7010600070106
[    0.000000] found SMP MP-table at [ffff8800000fda40] fda40
[    0.000000] init_memory_mapping: 0000000000000000-000000001fffd000
[    0.000000] RAMDISK: 1fc95000 - 1ffed000
[    0.000000] ACPI: RSDP 00000000000fd9f0 00014 (v00 BOCHS )
[    0.000000] ACPI: RSDT 000000001fffd6a0 00034 (v01 BOCHS  BXPCRSDT 00000001 BXPC 00000001)
[    0.000000] ACPI: FACP 000000001ffffe10 00074 (v01 BOCHS  BXPCFACP 00000001 BXPC 00000001)
[    0.000000] ACPI: DSDT 000000001fffd8c0 024F1 (v01   BXPC   BXDSDT 00000001 INTL 20090123)
[    0.000000] ACPI: FACS 000000001ffffdc0 00040
[    0.000000] ACPI: SSDT 000000001fffd820 0009E (v01 BOCHS  BXPCSSDT 00000001 BXPC 00000001)
[    0.000000] ACPI: APIC 000000001fffd730 00078 (v01 BOCHS  BXPCAPIC 00000001 BXPC 00000001)
[    0.000000] ACPI: SSDT 000000001fffd6e0 0004E (v01   BXPC BXSSDTPC 00000001 INTL 20090123)
[    0.000000] No NUMA configuration found
[    0.000000] Faking a node at 0000000000000000-000000001fffd000
[    0.000000] Initmem setup node 0 0000000000000000-000000001fffd000
[    0.000000]   NODE_DATA [000000001fff5000 - 000000001fff9fff]
[    0.000000] kvm-clock: Using msrs 4b564d01 and 4b564d00
[    0.000000] kvm-clock: cpu 0, msr 0:1cf7681, boot clock
[    0.000000] Zone PFN ranges:
[    0.000000]   DMA      0x00000010 -> 0x00001000
[    0.000000]   DMA32    0x00001000 -> 0x00100000
[    0.000000]   Normal   empty
[    0.000000] Movable zone start PFN for each node
[    0.000000] early_node_map[2] active PFN ranges
[    0.000000]     0: 0x00000010 -> 0x0000009d
[    0.000000]     0: 0x00000100 -> 0x0001fffd
[    0.000000] ACPI: PM-Timer IO Port: 0xb008
[    0.000000] ACPI: LAPIC (acpi_id[0x00] lapic_id[0x00] enabled)
[    0.000000] ACPI: LAPIC_NMI (acpi_id[0xff] dfl dfl lint[0x1])
[    0.000000] ACPI: IOAPIC (id[0x00] address[0xfec00000] gsi_base[0])
[    0.000000] IOAPIC[0]: apic_id 0, version 17, address 0xfec00000, GSI 0-23
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 5 global_irq 5 high level)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
[    0.000000] ACPI: INT_SRC_OVR (bus 0 bus_irq 10 global_irq 10 high level)
[    0.000000] ACPI ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
5

answered 2014-04-11 13:03:37 -0500

SGPJ gravatar image

updated 2014-04-18 09:32:44 -0500

smaffulli gravatar image

The quick steps:

  • Get to VM trough console in dashboard
  • assign an ip address (private ip) by sudo ifconfig <eth0> <ip> up
  • associate a floating IP
  • in security group, add rules like all ICMP, TCP, DNS & SSH
  • Try to ping vm floating IP from host machine.
edit flag offensive delete link more

Comments

What if I cannot get to VM through console in dashboard?

McCafe gravatar imageMcCafe ( 2015-04-16 16:25:44 -0500 )edit
0

answered 2015-10-17 11:11:02 -0500

HI after that also i am not communicating outside, please can any once to resolve this issue, and i am using Kilo.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-11 11:59:29 -0500

Seen: 1,419 times

Last updated: Apr 18 '14