Ask Your Question
0

Enable Swift in OpenStack Devstack

asked 2014-04-11 05:33:37 -0500

mani619cash gravatar image

I want to enable Swift in OpenStack that I have installed through DevStack

Actually I want to upload files using PHP Open-Cloud.

Is Swift necessary to upload files?

I have enable_service swift but it gives error like.

Internel Server Error 505 Failed to upload image
edit retag flag offensive close merge delete

Comments

I suggest you to first get your cloud running correctly with devstack and then do more sophisticated things. Edit your question to specify what is php open cloud, too.

smaffulli gravatar imagesmaffulli ( 2014-04-11 06:53:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-15 01:13:31 -0500

fifieldt gravatar image

It looks like you are using old instructions. Ensure

ENABLED_SERVICES+=,s-proxy,s-object,s-container,s-account

is in your local.conf

edit flag offensive delete link more

Comments

in your localrc?

clayg gravatar imageclayg ( 2014-04-16 18:04:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-11 05:33:37 -0500

Seen: 402 times

Last updated: Apr 15 '14