Ask Your Question
0

change novalocal suffix in HOSTNAME

asked 2014-04-09 14:08:04 -0500

vladber gravatar image

Hi,

After reboot the full hostname of instance is set as hostname.novalocal . We plan to install Oracle on VMs and need to cotrol a VM's hostnames . The default hostname may be found in the /etc/sysconfig/network like below is not good:

HOSTNAME=vmname.novalocal

How to disable automatic adding the "novalocal" suffix in the HOSTNAME ?

I defined the dhcp_domain=mydomain.com in the /etc/nova/nova.conf but this didn't help .After this config the hostname is set as HOSTNAME=vmname.example.com.novalocal

/Vlad

edit retag flag offensive close merge delete

Comments

Are you using nova-network or neutron for network services?

larsks gravatar imagelarsks ( 2014-04-09 20:43:25 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-04-18 04:47:49 -0500

fifieldt gravatar image

There was a discussion on the mailing list on this recently, the solution being here:

http://lists.openstack.org/pipermail/...

""" Setting dhcp_domain to an empty string in nova.conf on the Control node. For instance 'dhcp_domain='. An instances name can now be set to a FQDN which will then be passed cloud-init via the metadata server.

Secondly, The Neutron DHCP service sets the default DNS suffix for a NIC to openstacklocal . This causes delays in DNS lookups on external DNS servers, as the wrong domain is used by default. Similarly to the above, this can be resolve by setting 'dhcp_domain=' in the Neutron DHCP config file dhcp_agent.ini. Once this is set and the DHCP service restarted, the "--domain=<domain>" parameter no longer gets set """

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-09 14:08:04 -0500

Seen: 5,036 times

Last updated: Apr 18 '17