Ask Your Question
1

How to prevent cloud-init from disable ssh PasswordAuthentication? [closed]

asked 2014-04-08 07:36:42 -0500

senyapsudah gravatar image

Hi Guys,

anybody know how to prevent cloud init from keep disabling PasswordAuthentication options in ssh config? i did some research and found that it depends on ssh_pwauth. from what i have tested it still disabling the PasswordAuthentication options even when i set it to 0 or 1.

any good guidance from here?

thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-05 07:43:15.598895

Comments

Hi dbaxps,

i have no issue on setting the password to the instance, just what i'm confuse now is the cloud init keep disabling the PasswordAuthentication even thoug /etc/cloud/cloud.cfg has been set as true.

senyapsudah gravatar imagesenyapsudah ( 2014-04-08 18:06:28 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-04-08 19:48:08 -0500

senyapsudah gravatar image

Fuhh..so relief, after run few time test try and error found out that ssh_pwauth need to be set as true not 0 inside the /etc/cloud/cloud.cfg then import the image again. tested working fine after that.

Thanks dbaxps. you give it a clue there. :) so the issue solved now.

edit flag offensive delete link more
1

answered 2014-04-08 11:20:52 -0500

dbaxps gravatar image

updated 2014-04-08 11:54:31 -0500

Due to need set MTU 1454 for some time I used creating instances in cluster via command

            [root@dfw02 ~(keystone_boris)]$  nova boot --flavor 2 --user-data=./myfile.txt  
                --image 03c9ad20-b0a3-4b71-aa08-2728ecb66210 UbuntuTRS01
            where

            [root@dfw02 ~(keystone_boris)]$  cat ./myfile.txt
            #cloud-config
            password: mysecret
            chpasswd: { expire: False }
            ssh_pwauth: True

             Same is possible via Post Creation Tab's Customization Script Window
             in Dashboard. Instance been created won't require keypair at all.

            Just  
            # ssh ubuntu@compute-node will login you with password "mysecret"

            I am not sure that is what you are asking about.
            In meantime I set MTU via dhcp_agent.ini&dnsmasq.conf  and don't do it anymore

Tested just now $ ssh fedora@192.168.1.119

The authenticity of host '192.168.1.119 (192.168.1.119)' can't be established.
ECDSA key fingerprint is e7:ee:95:08:28:8d:32:58:fc:79:28:e5:d0:c7:6f:34.
Are ...
(more)
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-04-08 07:36:42 -0500

Seen: 14,260 times

Last updated: Apr 08 '14