Ask Your Question
3

DHCP discover request does not reach controller node.

asked 2014-04-08 04:53:24 -0500

Aditi Sharma gravatar image

I have a 2 node set with single interface. The interface is on the 192.168.10.0/24 subnet. One is with ip 160 and the other with 161

I am trying to create a flat network using neutron.

On the controller/network node, In the ovs_neutron_plugin.ini file:

Tenant_network_type //(commented )

Network_vlan_ranges = physnet1

Bridge_mappings = physnet1:br-ex

$ovs-vsctl show

Bridge br-int

     Port int-br-ex
       Interface int-br-ex

     Port br-int
        Interface br-int
            type: internal

   Tap interface “tapxxx”

Bridge br-ex
    Port br-ex
        Interface br-ex
            type: internal
    Port phy-br-ex
        Interface phy-br-ex
    Port "eth0"
        Interface "eth0"

The compute code has the same config as above, except the ‘Tap’ interface’ which is created by the dnsmasq process.

eth0 on both nodes are in promiscuous mode and attached to br-ex

I created a tenant, network and a subnet 198.168.10.0/24. I was able to spin a VM successfully on the compute node but it fails to allocate the IP address.

While creating the network the type was specified as ‘flat’

The horizon front-end displays the IP address as successfully allocated but it is not configured on the VM (ifconfig on VM). Dnsmasq is created correctly.

Using wireshark, on the compute node, I can see that the discover request being sent from the VM hardware address to br-int and also to phy-br-ex. However the interface, br-ex and eth0 which is attached to br-ex, does not receive the Discover request.

What happens to the connectivity from phy-br-ex to br-ex? Why does the discover request not show in br-ex and eth0 while it shows in br-int, int-br-ex and phy-br-ex.

Why does horizon show it as being allocated. Does the DNSmasq process allocate it without waiting for the discover request?

Is there anything wrong in the config files? Should we specify tenant_network? I left it commented for the flat network. The only difference from the guides is that we use the notification_driver = neutron.openstack.common.notifier.rpc_notifier instead of notification_driver = neutron.openstack.common.notifier.rabbit_notifier and control_exchange is default – commented.

I do not think it makes any difference to the network part but if someone could explain the reason for packets not showing in br-ex while it shows in phy-br-ex, it would be helpful.

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2014-04-30 07:37:38 -0500

davide gravatar image

Hi, I am having the very same problem! I am using neutron/Vlan. VMs spawned on the controller/NN get an IP while those on compute nodes don't. any clue?

Thanks, d.

edit flag offensive delete link more
0

answered 2014-04-27 02:47:00 -0500

DanIzack gravatar image

updated 2014-04-27 04:16:00 -0500

If you want flat network View Nova flat network or follow Single flat network - Neutron & L2 Agent

edit flag offensive delete link more

Comments

i had tried the flat network also but it still issues the same problem..

Aditi Sharma gravatar imageAditi Sharma ( 2014-04-28 02:07:24 -0500 )edit
0

answered 2014-04-25 03:52:26 -0500

nikhilnik11 gravatar image

koi fayda ni

edit flag offensive delete link more

Comments

Please don't spam the forum

Gaganjot Singh gravatar imageGaganjot Singh ( 2014-04-25 05:45:35 -0500 )edit

ok sure :P

nikhilnik11 gravatar imagenikhilnik11 ( 2014-05-02 07:34:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-08 04:53:24 -0500

Seen: 714 times

Last updated: Apr 30 '14