Ask Your Question

Am I approaching this correctly? (Neutron ML2 OVS)

asked 2014-04-06 04:53:37 -0500

rnorton gravatar image

updated 2014-04-06 05:32:53 -0500

So I've got 3 physical machines setup running Nova + Neutron. Each machine has 3 NICs:

  1. Openstack backend NIC - eth0 (Statically ssigned IPs on br-ext, this is attached to our normal local office network on the same subnet)
  2. Tenant network NIC - eth1
  3. Public/Internet NIC - eth2

I'm using a Cisco 3560G switch. eth0 and eth2 ports are setup like this:

interface GigabitEthernet0/1

switchport access vlan 900 (or 902 for eth2)

switchport mode access

speed 1000

duplex full

storm-control broadcast level 5.00

eth1 ports are setup like this:

interface GigabitEthernet0/29

switchport access vlan 901

switchport trunk encapsulation dot1q

switchport trunk native vlan 901

switchport trunk allowed vlan 1-1000

switchport mode trunk

storm-control broadcast level 5.00


I have plugged two laptops into the eth1 ports (tenant networks), setup vlan tagging, and confirmed that they can talk to each other on whatever NIC-configured vlan.

My Neutron.conf:

My l3_agent.ini:

My dhcp_agent.ini:

My plugin.ini (ml2_conf.ini):

Neutron net-list: ( is on VLAN 401)

Neutron subnet-list:

ovs-vsctl show on controller (hosting compute nodes as well):

ovs-vsclt show on compute node #1:

ovs-vsctl show on compute node #2:

Here's the problem:

  1. A instance can only get a DHCP'ed if that instance's host (and only that host) is running neutron-dhcp-agent on the same machine.

  2. Only physical machine's instances can ping the gateway and access the internet. All instance's can ping other instances on the same node.

My Questions:

  1. Am I approaching this correctly? Does my network setup make sense to the casual observer?

  2. Does neutron-server, l3-agent, dhcp-agent, openvswitch-agent need to be running on all compute nodes?

  3. Does it matter where you run neutron router-gateway-set? It seems to create the routing bridge on the exact machine you run it on.

Any help is greatly appreciated!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-04-10 00:17:06 -0500

rnorton gravatar image

Ended up figuring this out: ovs-vsctl set interface eth1 other-config:enable-vlan-splinters=true

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-04-06 04:53:37 -0500

Seen: 386 times

Last updated: Apr 10 '14