Ask Your Question
0

simple network configuration

asked 2014-04-02 08:07:19 -0600

Czechu gravatar image

updated 2014-04-02 08:07:50 -0600

Hi All,

I try to configure neutron/open-switch to work only with my local network, but without any effect.

My physical local net: 192.168.1.0/24

All OpenStack modules are installed on the same node. OpenStack Node networks:

eth0: static 192.168.1.50
eth1: in this moment not configured ? only allow-hotplug eth1

openstack# ovs-vsctl list-br
br-eth1
br-int

openstack# ovs-vsctl list-ports br-eth1
eth1
phy-br-eth1


 openstack#  neutron net-show b009e731-aa82-4adb-a02a-c3b1f2b0b2d0
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | b009e731-aa82-4adb-a02a-c3b1f2b0b2d0 |
| name                      | Public                               |
| provider:network_type     | vlan                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  | 3                                    |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | c1411c10-833b-4dd6-8aac-f371b029d9dd |
| tenant_id                 | 24ed12f3ac7143158e538250b1358e7d     |
+---------------------------+--------------------------------------+

 openstack#  neutron subnet-show c1411c10-833b-4dd6-8aac-f371b029d9dd
+------------------+----------------------------------------------------+
| Field            | Value                                              |
+------------------+----------------------------------------------------+
| allocation_pools | {"start": "192.168.1.100", "end": "192.168.1.222"} |
| cidr             | 192.168.1.0/24                                     |
| dns_nameservers  |                                                    |
| enable_dhcp      | False                                              |
| gateway_ip       | 192.168.1.1                                        |
| host_routes      |                                                    |
| id               | c1411c10-833b-4dd6-8aac-f371b029d9dd               |
| ip_version       | 4                                                  |
| name             |                                                    |
| network_id       | b009e731-aa82-4adb-a02a-c3b1f2b0b2d0               |
| tenant_id        | 24ed12f3ac7143158e538250b1358e7d                   |
+------------------+----------------------------------------------------+


openstack# cat /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:1:4094
bridge_mappings = physnet1:br-eth1

I launch instance with IP 192.168.1.100

    openstack# arp
        Address                  HWtype  HWaddress           Flags Mask            Iface
        192.168.1.100                    (incomplete)                              eth0
             .....

But I can't ping or nmap this VM ?

Where I make mistake ?

Or what I should read ?

I read everything on openstack page, but this guides for me are seems incomplete

I'm new in virtual networks.

Please help :)

edit retag flag offensive close merge delete

Comments

your config is ok if physical port for eth1 is cabled into a physical switchport that allows tagged traffic with vlan id 3. But I suspect that is not the case. You will need to tell of more about the physical config.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-04-02 10:06:21 -0600 )edit

I want to connect to VM from normal local net connected to eth1 in OpenStack eg.

192.168.0.1 <- router
192.168.0.2 <- me
192.168.0.3 <- openstack eth0
....
192.168.0.100 <- VM 1 on openstack ?
192.168.0.101 <- VM 2 on openstack ?

it's possible ?

I suspect that network_type=vlan it's not best solution ? What type I should use ?

When I ping VM 192.168.0.100 I see on tcpdump -i br-int this ARP request. But still without effect.

Czechu gravatar imageCzechu ( 2014-04-02 10:44:49 -0600 )edit
1

ok, so I think you want "me" (the host OS) to be using eth0. Then use a flat net instead of vlan. The bridge br-eth1 has eth1 and eth1 should not have an ip address. Of course eth1 should be cabled to your switch/router too.

tenant_network_type = flat
network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-eth1
darragh-oreilly gravatar imagedarragh-oreilly ( 2014-04-02 11:40:12 -0600 )edit

Thanks this help.

Czechu gravatar imageCzechu ( 2014-04-03 09:33:03 -0600 )edit

that's good. I forgot to mention that you might want to run a dhcp-agent to assign the neutron allocated ip addresses. You might also want to tell your physical switch/router that 192.168.1.100 to 192.168.1.222 is reserved.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-04-03 12:50:12 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-04-02 12:05:01 -0600

sateesh gravatar image

Hi,

Hope you have installed all require network module(neutronserver,l3-agent,dhcp,ovs-agent) Hope your are using KVM hypervisor? Did you configure any router? if not configure network and add that interface to router. configure ovs vsctl add-br br-int configure ovs vsctl add-br br-ex configure ovs vsctl add-port br-ex ethX(which connects to external/internet) Assign external IP add to br-ex (ifconfig br-ex 192.168.1.x up) Check interface status of all (ip link show) if you are using Ubuntu. Let me know are you ping GW from VM?

Please refer below document for better understanding

https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/OVS_SingleNode/OpenStack_Grizzly_Install_Guide.rst (https://github.com/mseknibilel/OpenSt...)

For better understanding on neutron networking flow please go thru below document.

http://developer.rackspace.com/blog/categories/networking/ (http://developer.rackspace.com/blog/c...) Regards Sateesh

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-02 08:07:19 -0600

Seen: 486 times

Last updated: Apr 02 '14