Multicast messages originating from vm not reachable vms on different physical servers. [closed]

asked 2014-04-02 00:07:54 -0500

Pulkit gravatar image

updated 2014-04-02 00:08:34 -0500

I have an Openstask cluster running folsom on ubuntu 12.04 LTS. I am having a weird issue where in the multicast packets from vm1 running on physical server 1 do not reach vm2 running on physical server 2. however all on the vm's on same physical server receive multicast messages originating from any other vm running on the same physical server.

What is weird is from virtual machine vm3 running on physical server 3 multicast packets reach vm2 and vm1 above. I am looking for some specific help I could get on debugging this.

My guest OS is centos 6.4. I have the following sysctl.conf file in the guest os.

Do not accept source routing

net.ipv4.conf.default.accept_source_route = 0

Controls the System Request debugging functionality of the kernel

kernel.sysrq = 0

Controls whether core dumps will append the PID to the core filename

Useful for debugging multi-threaded applications

kernel.core_uses_pid = 1

Controls the use of TCP syncookies

net.ipv4.tcp_syncookies = 1

Controls the maximum size of a message, in bytes

kernel.msgmnb = 65536

Controls the default maxmimum size of a mesage queue

kernel.msgmax = 65536

Controls the maximum shared segment size, in bytes

kernel.shmmax = 68719476736

Controls the maximum number of shared memory segments, in pages

kernel.shmall = 4294967296

fs.file-max=209702

Increase Linux TCP buffer limits

net.core.optmem_max=10000000 net.core.rmem_default=10000000 net.core.rmem_max=10000000 net.core.wmem_default=10000000 net.core.wmem_max=10000000 net.ipv4.conf.all.rp_filter=1 net.ipv4.tcp_max_tw_buckets=2000000 net.ipv4.tcp_mem=30000000 30000000 30000000 net.ipv4.tcp_rmem=30000000 30000000 30000000 net.ipv4.tcp_wmem=30000000 30000000 30000000

Specify available set of TCP/IP ports available

net.ipv4.ip_local_port_range = 32768 65000

Disable IP packet forwarding

net.ipv4.ip_forward = 0

Controls source route verification

#net.ipv4.conf.default.rp_filter = 1

Turn on tcp_timestamps

net.ipv4.tcp_timestamps = 1

Decrease the time default value for tcp_fin_timeout connection

net.ipv4.tcp_fin_timeout = 30

Decrease the time default value for tcp_keepalive_time connection

net.ipv4.tcp_keepalive_time = 1800

Turn on tcp_window_scaling

net.ipv4.tcp_window_scaling = 1

Turn on the tcp_sack

net.ipv4.tcp_sack = 1

for multicast

net.ipv4.igmp_max_memberships = 4096

sysctl.conf on the physical server is

Do not accept source routing

net.ipv4.conf.default.accept_source_route = 0

Controls the System Request debugging functionality of the kernel

kernel.sysrq = 0

Controls whether core dumps will append the PID to the core filename

Useful for debugging multi-threaded applications

kernel.core_uses_pid = 1

Controls the use of TCP syncookies

net.ipv4.tcp_syncookies = 1

Controls the maximum size of a message, in bytes

kernel.msgmnb = 65536

Controls the default maxmimum size of a mesage queue

kernel.msgmax = 65536

Controls the maximum shared segment size, in bytes

kernel.shmmax = 68719476736

Controls the maximum number of shared memory segments, in pages

kernel.shmall = 4294967296 fs.file-max=209702

net.ipv4.ip_forward=1

Increase Linux TCP buffer limits

net.core.optmem_max=10000000 net.core.rmem_default=10000000 net.core.rmem_max=10000000 net.core.wmem_default=10000000 net.core.wmem_max=10000000 #net.ipv4.conf.all.rp_filter=1 ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-06-21 14:21:40.526722

Comments

The version of OpenStack that this is opened against has been declared EOL as per http://releases.openstack.org/ Please open a new issue if you are still seeing this problem with a more recent, supported version of OpenStack. Thanks.

rbowen gravatar imagerbowen ( 2016-06-21 14:21:36 -0500 )edit