Ask Your Question

Can we set admin password return on horizon for every new instance create?

asked 2014-04-01 04:23:23 -0500

senyapsudah gravatar image

i would like to get some clarification on how can we enable horizon to enable admin password creation inside horizon? please advise.

btw, i did enable nova.conf as per below:


enable_instance_password = True

[libvirt] cpu_mode = host-passthrough

cpu_model = host-passthrough

inject_password = true

password_length = 10

inject_key = True

still not able to inject the password to the new image. please advise.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2014-04-01 06:05:06 -0500

jpichon gravatar image

The 'can_set_password' option might be of interest to you, see . However I think it's only compatible with certain hypervisors.

edit flag offensive delete link more


yes, looking forward on that. i believe it should be working on KVM rite? i did some reading and seems like by default for KVM/Qemu it is disable by default so need to enable it manually.

so i assume that KVM should be supported rite?

senyapsudah gravatar imagesenyapsudah ( 2014-04-01 21:17:59 -0500 )edit

I don't know the answer to that, but if you've tested it and it works, cool!

jpichon gravatar imagejpichon ( 2014-04-02 02:59:14 -0500 )edit

Still not able to get it working.. i believe the functions are relying on another process to do that.. do you guys have any idea? how libguestfs. is it required to be installed?

senyapsudah gravatar imagesenyapsudah ( 2014-04-06 10:01:12 -0500 )edit

answered 2014-04-07 09:59:17 -0500

senyapsudah gravatar image

After for so long trying i found that this could be done and successfully inject the password which i set from horizon to the instance.

first, i need to set 'can_set_password' inside /etc/openstack-dashboard/ the syntax should be as per below:

'can_set_mount_point': True,
'can_set_password': True,


then i need to add below setting inside /etc/nova/nova.conf


if you refer to the documentation it state that we need to use

inject_password = true

i did try this but it doesn't do the job. so far i can see also there lots of configuration which has been added and probably will only work with icehouse.

if you use a prebuilt cloud image, you need to make sure that your /etc/ssh/ssd_config already permit root login and password authentications

PermitRootLogin yes
PasswordAuthentication yes


edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-04-01 04:23:23 -0500

Seen: 1,483 times

Last updated: Apr 07 '14