Ask Your Question
0

neutron and external network access

asked 2014-03-31 23:22:00 -0500

nivaac gravatar image

updated 2014-04-01 02:40:18 -0500

Hello,

I’m setting up a test Openstack cloud environment for our testing purpose. Cloud is setup with 3 VMs(Controller node, Network node and a Compute Node) on a vmware server. In the cloud,

Network node has 3 NICs, eth0(guest data), eth1(management) and eth2(public network). 
Compute node has 2 NICs, eth0(guest data), eth1(management)
Controller node has 2 NICS, eth0( for external access) and eth1(management)

And, networking is setup with Neutron OVS with vlan.

The physical network associated with the public network is labelled as physnet1, and the physical network associated with the data network is labelled as physnet2. 'br-ex' is the network device to provide external access and br-ex is bridged to eth2 on the Network node.

-> Network node :

[root@neutron ~]# ovs-vsctl show 
4cdcb1a4-1f98-4687-b03e-bfd063fb507a
    Bridge br-ex
        Port "qg-0e7e9672-08"
            Interface "qg-0e7e9672-08"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth2"
            Interface "eth2"
        Port phy-br-ex
            Interface phy-br-ex
    Bridge "br-eth0"
        Port "phy-br-eth0"
            Interface "phy-br-eth0"
        Port "eth0"
            Interface "eth0"
        Port "br-eth0"
            Interface "br-eth0"
                type: internal
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port int-br-ex
            Interface int-br-ex
        Port "int-br-eth0"
            Interface "int-br-eth0"
    ovs_version: "1.11.0"

-> Compute node:

[root@compute1 ~]# ovs-vsctl show 
c0861526-be5b-4bee-a071-888864360942
    Bridge br-int
        Port "int-br-eth0"
            Interface "int-br-eth0"
        Port br-int
            Interface br-int
                type: internal
    Bridge "br-eth0"
        Port "eth0"
            Interface "eth0"
        Port "phy-br-eth0"
            Interface "phy-br-eth0"
        Port "br-eth0"
            Interface "br-eth0"
                type: internal
    ovs_version: "1.11.0"

And I’ve the following configuration in /etc/neutron/plugin.ini on Network and Compute node:

-> Network node:

[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet2:101:120
tenant_network_type=vlan
enable_tunneling=False
integration_bridge=br-int
bridge_mappings=physnet1:br-ex,physnet2:br-eth0

-> Compute node:

[OVS]
vxlan_udp_port=4789
network_vlan_ranges=physnet2:101:120
tenant_network_type=vlan
enable_tunneling=False
integration_bridge=br-int
bridge_mappings=physnet2:br-eth0

I’m able to define the public network with physical_network physnet1 but when I create a private network for a tenant with physical_network physnet2, I get the following error message:


[root@controller ~(ks_admin)]# tenant=$(keystone tenant-list|awk '/BOSH/ {print $2}')
[root@controller ~(ks_admin)]# neutron net-create --tenant-id $tenant net01           --provider:network_type vlan           --provider:physical_network physnet2           --provider:segmentation_id 101

400-{u'NeutronError': {u'message': u'Invalid input for operation: Unknown provider:physical_network physnet2.', u'type': u'InvalidInput', u'detail': u''}}

On checking, the openvswitch-agent.log on network node and compute node, I could see mapping has added for ‘physnet2’.

-> Network node:


2014-03-31 12:15:42.125 14093 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Mapping physical network physnet2 to bridge br-eth0
2014-03-31 12:15:43.667 14093 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Mapping physical network physnet1 to bridge br-ex
2014-03-31 12:15:46.243 14093 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Agent initialized successfully, now running...

-> Compute node:


2014-03-31 12:20:29.551 15387 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Mapping physical network physnet2 to bridge br-eth0
2014-03-31 12:20:33.153 15387 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Agent initialized successfully, now running...

Do I need to define a separate 'network_vlan_range' for physnet2 to get working?

Also, I've the external network for floating IPs(public access) for the ...

(more)
edit retag flag offensive close merge delete

Comments

What OS are your VMs running ? RDO Hangout (02/27/14) contains packstack's answer-file matches your request on CentOS 6.5. It's publicly available -Link for Hangout Sorry, I believe Lars setup is using GRE tunneling , not vlan, but Controller+NeutronServer+Compute on separate hosts (VMs) , like you need

http://oddbit.com/rdo-hangout-multino...

Update row :- CONFIG_NOVA_COMPUTE_HOSTS=10.15.0.2,10.15.0.4 . . . . . Yes - GRE CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=gre

dbaxps gravatar imagedbaxps ( 2014-04-01 02:54:56 -0500 )edit

OS is centos 6.5 and openstack is installed with packstack..

Thanks for the link. I'll check it out.

nivaac gravatar imagenivaac ( 2014-04-01 09:37:55 -0500 )edit

1 answer

Sort by » oldest newest most voted
-1

answered 2014-04-01 12:30:38 -0500

dbaxps gravatar image

Perform install from scratch with Controller+NeutronServer+( 1)* Compute node via adopting Lars Kellogg-Stedman RDO Hangout (02/27/14) sample answer-file , keeping in mind to set MTU to 1454 on VMs (Neutron GRE+OVS configuration). Link to How to set MTU = 1454 automatically

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-31 23:22:00 -0500

Seen: 1,516 times

Last updated: Apr 01 '14