Ask Your Question
0

Flat DHCP network: vnet missing, can't ping instance

asked 2014-03-31 19:45:56 -0600

updated 2014-03-31 20:00:00 -0600

I am on a steep learning curve learning OpenStack and consequently some networking as well. So, consider this a newbie question.

After following the http://docs.openstack.org/havana/install-guide/install/apt/content/ (Ubuntu installation instructions), I am now at the end of chapter 5 and have successfully launched an instance. My servers are VirtualBox machines, and since kvm doesn't work on virtual CPUs I use qemu instead. Another deviation from the instructions: Instead of leaving it alone, I gave eth1 on the compute node a static IP address 10.0.0.11 in /etc/network/interfaces. All the rest should be exactly as in the documentation.

The problem is that I can't ping the instance from the compute node.

Upon checking, I find that there is no vnet0 interface, and the br100 bridge has only one slave, eth1. /etc/libvirt/qemu/instancexxx.xml doesn't mention vnet either, in contrast to the http://docs.openstack.org/trunk/openstack-ops/content/network_troubleshooting.html (Network Troubleshooting instructions).

Obviously I did something wrong. My questions are: Where would I start looking what went wrong? How is it possible that the vnet interface was not set up? And of course, how can I repair this without reinstalling everything. I am less interested in solutions than in ways to find a solution.

I am unable to attach files, so I am just pasting the ip addr list output, the instance....xml file, and the networking portion from nova.conf.

----------------------------------------- ip a l output ---------------------------------------

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet 169.254.169.254/32 scope link lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:9b:d4:b3 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.11/24 brd 192.168.0.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe9b:d4b3/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master br100 state UP qlen 1000
    link/ether 08:00:27:27:78:72 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a00:27ff:fe27:7872/64 scope link
       valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 08:00:27:74:87:44 brd ff:ff:ff:ff:ff:ff
    inet 10.0.4.15/24 brd 10.0.4.255 scope global eth2
       valid_lft forever preferred_lft forever
    inet6 fe80::a00:27ff:fe74:8744/64 scope link
       valid_lft forever preferred_lft forever
5: br100: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP
    link/ether 08:00:27:27:78:72 brd ff:ff:ff:ff ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-01 23:45:51 -0600

fifieldt gravatar image

Instead of leaving it alone, I gave eth1 on the compute node a static IP address 10.0.0.11 in /etc/network/interfaces.

That would be why :) You need to remove the static IP assignment so that nova can manage the IP address and create the interfaces successfully.

edit flag offensive delete link more

Comments

Thanks. Today I was able to access the VM, and I could see the vnet0 interface, but I could swear that the eth1 address was set at boot time. Since I have multiple other issues with the network (which may well be the cause of my problem), I am unable to check this unfortunately.

Bernd Bausch gravatar imageBernd Bausch ( 2014-04-03 00:40:24 -0600 )edit

In a second test environment, this time based on Centos, I have no bridge problems although eth1, one of the bridge slaves, does get an IP address at boot time.

Bernd Bausch gravatar imageBernd Bausch ( 2014-04-03 00:42:22 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-31 19:45:56 -0600

Seen: 547 times

Last updated: Apr 01 '14