cloudify openstack grizzly

asked 2013-06-27 10:14:33 -0600

polslinux gravatar image

I have a problem with Cloudify (both 2.5 and 2.6-rc release).

I have an All-In-One Openstack 2013.1.1 setup and i'm trying to use cloudify to bootstrap a cirros 0.3.1 vm.

My quantum configuration is:

a private fixed ip for vm management

floating ip taken from the pool ( is my lan)

When i deploy a vm first an ip from is given (i cannot reach it from PCs because it is only for vm management) and then i associate a floating ip with which i can ping the/ssh into deployed machine.

The problem is that when i do:

bootstrap-cloud openstack

because cloudify stay forever into "attempting to access management vm" and this is due to the fact that is not reachable.

What can i do to get cloudify take the floating ip instead of the fixed one?


edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2013-06-28 15:04:38 -0600

tamirko gravatar image

Hi ,

You can configure private and public IP addresses in Cloudify as described (here).

(This works only on Cloudify 2.6).

You also need to :

1) Make sure that your Openstack provider supports auto assignment of floating IPs and that it has a default floating IPs pool name.

i.e. : The following two properties must be set in the nova.conf of your openstack cloud : default_floating_pool="nova"

auto_assign_floating_ip = True

2) Pass "autoAssignFloatingIp" : true in the options of the computeTemplate in the openstack cloud driver.

Here's a working example of an Openstack cloud driver : You can use the (cloud driver) and its corresponding (properties file) "as is".


Tamir Korem

Cloudify Community Manager

edit flag offensive delete link more


Is it possible to select which openstack networks the cloudify management machine connects to? By default cloudify select all networks but this choice is giving me troubles, the VMs needs to be connected only to the int network, which assigns a Floating Ip, and not also directly connected to ext

Tyyko gravatar imageTyyko ( 2013-06-30 07:49:47 -0600 )edit

but does it works with Quantum? Because i don't use nova-network!

polslinux gravatar imagepolslinux ( 2013-07-01 15:30:38 -0600 )edit

i have a problem because the floating ip is not associated :(

polslinux gravatar imagepolslinux ( 2013-07-01 15:43:19 -0600 )edit

Cloudify does not support Openstack Quantum in versions 2.5/2.6. As a result, VMs will start in all of the fixed networks. You can always create a custom cloud driver that tweaks the default cloud driver and adds functionality you need.

barakme gravatar imagebarakme ( 2013-07-02 04:59:57 -0600 )edit

+barakme: i think that this is the only thing i can do... :)

polslinux gravatar imagepolslinux ( 2013-07-03 16:17:38 -0600 )edit

answered 2013-06-27 23:39:58 -0600

Bhavaniprasad gravatar image


sorry becuase this is not related to your answer but please help me in grizzly quantum. i am not able ping the instance and not able to do ssh also. could you please provide steps to resolve it. i have installed it in ubuntu12.04 ,single node. i have crated private series of ip and externel ip series also. i did associcate with flaoting ip address also but still i am not able to. can you please provide pointers or documentation on this.

Thanks in advance.

Regards, BhavaniPrasad.

edit flag offensive delete link more


this is what i've done:

polslinux gravatar imagepolslinux ( 2013-06-28 02:41:02 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2013-06-27 10:14:33 -0600

Seen: 590 times

Last updated: Jun 28 '13