Ask Your Question
1

Horizon sends wrong REST request when spice is enabled

asked 2014-03-31 09:05:04 -0500

baboune gravatar image

I am using Havana on Ubuntu12.04 and am trying to switch from novnc to spice.

Controller: apt-get install nova-spiceproxy spice-html5

Changed the nova-conf on controller to:

novnc_Enabled=false
[spice]
enabled=true
html5proxy_base_url=http://CONTROLLER_IP:6082/spice_auto.html
server_listen=0.0.0.0
server_proxyclient_address=CONTROLLER_IP
keymap=en-us

And the compute node to:

[spice]
agent_enabled=true
enabled=true
html5proxy_base_url=http://CONTROLLER_IP:6082/spice_auto.html    
keymap=en-us    
server_listen=0.0.0.0
server_proxyclient_address=COMPUTE_IP

When using REST API, I can get teh spice console to a created VM and access it. the url is in the following format: http://CONTROLLER_IP:6082/spice_auto.html?token=91f2e4a3-43a5-4ec1-81aa-874cdf2a3340 (http://CONTROLLER_IP:6082/spice_auto....)

But in Horizon, it always points to http://127.0.0.1:6080/vnc_auto.html?token=b49cfce1-d0a0-4da1-8485-1b3d8ed62249&title=cirros-f44cb1db-3e44-47a0-85d4-e5a26290ef45(f44cb1db-3e44-47a0-85d4-e5a26290ef45) (http://127.0.0.1:6080/vnc_auto.html?t...) .
Basically an invalid URL. It is still looking for the novnc link.

In the /var/log/apache2/error.log file, I can see that horizon is still requesting a VNC console type and not a spice one.

[Mon Mar 31 13:55:11 2014] [error] 
[Mon Mar 31 13:55:11 2014] [error] REQ: curl -i http://147.214.206.185:8774/v2/519c6e2d263049adba404441f18aab60/servers/f44cb1db-3e44-47a0-85d4-e5a26290ef45/action -X POST -H "X-Auth-Project-Id: 519c6e2d263049adba404441f18aab60" -H "User-Agent: python-novaclient" -H "Content-Type: application/json" -H "Accept: application/json" -H "X-Auth-Token: 8936b8b04124cfc1b386daead1fe5426" -d '{"os-getVNCConsole": {"type": "novnc"}}'
[Mon Mar 31 13:55:11 2014] [error]

What is missing to inform horizon that this VM should use a spice console and not a novnc one?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-03-31 13:29:16 -0500

larsks gravatar image

Have you tried changing the CONSOLE_TYPE setting in /etc/openstack-dashboard/local_settings to SPICE?

edit flag offensive delete link more

Comments

1

I tried to put SPICE and it does solve the problem.

Though, by default, CONSOLE_TYPE is set to AUTO.

Does not AUTO support both vnc and spice?

baboune gravatar imagebaboune ( 2014-04-01 02:18:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-31 09:05:04 -0500

Seen: 450 times

Last updated: Mar 31 '14