Ask Your Question
1

Neutron FWaaS in PENDING_CREATE state

asked 2014-03-29 23:25:19 -0500

sateesh gravatar image

updated 2014-03-31 03:55:40 -0500

darragh-oreilly gravatar image

Hi,

I have enabled firewall in neutron.conf at controller (where neutron server installed) and Neutron node(where agents are installed)..after I create a firewall in dashboard its showing as PENDING_CREATE State not showing as active, all basic networking is working fine (used GRE tunnel). The changes made in Controller and neutron node..

Controller: service_plugins = neutron.services.firewall.fwaas_plugin.FirewallPlugin

Neutron Node:

[fwaas]
driver = neutron.services.firewall.drivers.linux.iptables_fwaas.IptablesFwaasDriver
enabled = True

Is anything I am issuing here please suggest me.

Regards Sateesh

edit retag flag offensive close merge delete

Comments

I think you just need to create a router and add a subnet to it. Then it will go active.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-03-31 03:53:52 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
0

answered 2016-12-29 13:19:24 -0500

Dinesh Kavuru gravatar image

Actually, you should first have enabled = true and then the driver entry. Also include agent-version = v1.

edit flag offensive delete link more
0

answered 2014-03-31 06:20:08 -0500

sateesh gravatar image

Hi,

Router is in place and its working, after that only created router. please let me know anything i am missed apart from above configuration.

Regards Sateesh

edit flag offensive delete link more
0

answered 2014-08-05 05:03:38 -0500

Beny gravatar image

Hi,

Try to restart all the neutron services and check. It worked for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-29 23:25:19 -0500

Seen: 1,512 times

Last updated: Aug 05 '14