Ask Your Question

Cannot ping external network from VM [closed]

asked 2014-03-28 16:03:05 -0500

Gerardo-Alfredo gravatar image

updated 2014-07-11 13:17:54 -0500

smaffulli gravatar image

Hello, i got a problem with OpenStack Havana deployment using nova-network FlatDHCPmanager i was following the setup of:

The deal is simple, im using Centos 6.5 and the latest version of Havana i have:

2 Node NIC's

  • eth0 internal (, X.X.X.12)
  • eth1 external (DHCP)

Controller Node

  • eth0 internal (
  • eth1 external (

So i have everthing well done until here, the problem comes when I launch the instances, I cannot ping their respective floating IP from any node on the "cluster", moreover, I can ssh from external network (Like my house for example), but the virtual machine cannot ping nor ping , I dont know why.

Tracing with tcpdump shows that packets arrive to br100 on each node (im using multi_host=True) but they cant reach to the physical eth1 of my compute nodes

Can anyone tell me where can be my problem in nova? I can post logs, conf files if ask for any

Regards Gerardo.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-03-31 14:56:06.845420

5 answers

Sort by ยป oldest newest most voted

answered 2014-03-31 13:32:05 -0500

Gerardo-Alfredo gravatar image

updated 2014-03-31 13:32:34 -0500

Thanks for your responses, we finally managed to solve this problem.

We had to change in the compute nova.conf file this line

public_interface = eth1

for this:

public_interface = eth0

And when we create the virtual network we had to change some params:

nova network-create vmnet --fixed-range-v4= \
--bridge=br100 --multi-host=T

For this:

nova network-create vmnet --fixed-range-v4= \ 
--bridge=br100 --bridge-interface=eth0 --multi-host=T

This allow us now to access to internet...

By the way we have a sub-interface (eth0:0) thats where the internet comes from =)

Regards Gerardo.

edit flag offensive delete link more


I am also facing same issue, I am using Fuel 4.0 installer and same network setup as the one mentioned above. I could not understand the solution completely . Can you please help me with this ? Where should I change the parameters related to virtual network? I have public_interface = eth1 in nova.conf. Is this correct ?

Gowri gravatar imageGowri ( 2014-04-01 00:01:05 -0500 )edit

Yeah, you need to make the change on every node with nova-network in your multi-host installation my friend.

And the step of creating the Virtual Network on Installing Compute Services (Nova) must have the --brige interface set. Hope you can fix it. Regards Gerardo

Gerardo-Alfredo gravatar imageGerardo-Alfredo ( 2014-04-01 00:11:40 -0500 )edit

answered 2014-03-29 13:54:36 -0500

SGPJ gravatar image

I am also facing similar issue.

edit flag offensive delete link more

answered 2014-03-31 00:24:19 -0500

noah8713 gravatar image

I too faced same issue.

I also used the same configuration with 2 NIC:

Please refer this steps for creating routers for VM which helped me fix my issue: (


edit flag offensive delete link more


Does this work with nova-network installation? I think this if for neutron and im using the basic install

Gerardo-Alfredo gravatar imageGerardo-Alfredo ( 2014-03-31 11:54:23 -0500 )edit

answered 2014-03-31 05:53:45 -0500

Choco gravatar image

I face the same things since a few months but i really don't know if this is a bug or intended. The floating ips are routed with NAT from your Openstack node so instances shouldn't be able to know which floating ip is allocated to them.

It's like in your local network. Your PC doesn't know which ports on your router he gets to talk with the rest of the internet, does he? Just because we are using now full IPs instead of IP+Ports doesn't mean NAT-behaviour will change.

I'm just using internal IPs and told all my colleagues to do the same. But perhaps I'm wrong and someone will post a solution and I can make my colleagues happy again.

edit flag offensive delete link more



I dont understand why it happens, i wouldn't mind if I couldn't make ssh from external network, but my issue is that I cannot make even apt-get install "stuff" or a simple ping. I believe there is something wrong with those NAT rules but i don't understand them

Gerardo-Alfredo gravatar imageGerardo-Alfredo ( 2014-03-31 11:53:10 -0500 )edit

I have to say that I seem to ignored to a few facts from your first post. It's not normal that you can't ping external IPs (e.g. ). I tought that you can't ping other instances with their respective floating ip from another instance. But you seem to have found the solution!

Choco gravatar imageChoco ( 2014-04-07 05:03:56 -0500 )edit

answered 2014-03-30 03:51:20 -0500

Dan82 gravatar image

updated 2014-03-30 03:54:22 -0500


I got a similar issue after installing test configuration based OpenStack training guides pages for VirtualBox ( ( ).

After install reboot, I was unable to reach external network (, or even host machine).

I modified /etc/network/interfaces configuration file provided by training guide because two gateways were declared in this file and it was probably the origin of the issue (See following bug link in order to see my current interfaces configuration). As I'm not a network expert, I can't ensure my configuration is 100% OK.

I submitted a bug about this issue ( ( )

Regards, Dan

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-03-28 16:03:05 -0500

Seen: 7,820 times

Last updated: Jul 11 '14