Ask Your Question

Nova shows different IP than given by external DHCP server

asked 2014-03-28 14:39:34 -0600

Chris gravatar image

updated 2014-04-01 13:17:40 -0600

darragh-oreilly gravatar image

I am using neutron and I have a subnet created with --disable-dhcp, e.g.,

neutron subnet-create --tenant-id 5edf2827a9454de49a45fafd3f5ab8df --name subnet_a_b_c --ip-version 4 --gateway a.b.c.3 --disable-dhcp ext_net_a_b_c a.b.c.0/24

At the same time, I have another physical DHCP server providing IP address from a.b.c.0 subnet.

When an instance is launched, nova show <instance-id> still shows an IP address (but a wrong one).

I wonder if openstack just blindly pick one IP from a.b.c.0.

Is there a way to let the real IP address show up in "nova show <instance-id>"?

edit retag flag offensive close merge delete


hi, did you already had the chance to implement this? I'm currently stuck at the same issue, where I would need to configure and enable an external DHCP server to provide IP addresses to my 2nd provider network

fattony666 gravatar imagefattony666 ( 2018-09-05 07:12:36 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2014-04-01 13:28:31 -0600

darragh-oreilly gravatar image

Neutron uses an algorithm to allocate IP addresses from the subnet's allocation_pools. I don't believe that this is currently configurable. Nova gets the IP info from Neutron, and Neutron is not aware that you are using an external DHCP server.

In theory you could do a script to preallocate Neutron ports and have your DHCP server use these mac/ip pairs. Then boot the instances to these ports. Or write your own DHCP driver for the Neutron DHCP agent that somehow interfaces with the real DHCP server.

edit flag offensive delete link more

answered 2014-04-01 22:45:16 -0600

tahder gravatar image

Did you configure your Neutron DHCP Agent? say #neutron-dhcp-setup --plugin openvswitch (I assume you configure the /etc/neutron/neutron.conf to add the core_plugins and control_exchange). Or maybe check the /etc/neutron/dhcp_agent.ini (it is where the location of the dhcp configs, add the root_helper)

Try to restart the server (but you need to reboot the VMs coz sometimes restarting the network doesn't updated to the neutron dhcp): /etc/init.d/neutron-dhcp-agent restart chkonfig neutron-dhcp-agent on

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools



Asked: 2014-03-28 14:39:34 -0600

Seen: 1,349 times

Last updated: Apr 01 '14