Ask Your Question
5

Why is this ovs-vsctl running so often

asked 2013-06-26 18:47:18 -0500

mark0978 gravatar image

Below is auth.log from my system, why is this running so often? As soon as it finishes, it runs again, without any kind of pause between it. Auth.log is now 1.2GB and growing!

Jun 26 18:41:56 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface int-br-ex external_ids
Jun 26 18:41:56 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:56 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:56 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:56 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface tap9d8e8e1a-9d external_ids
Jun 26 18:41:56 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:56 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface patch-tun external_ids
Jun 26 18:41:56 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:57 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface tap4b8ac2f1-95 external_ids
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:57 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface tapb9203385-4c external_ids
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:57 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface tap64ef0cad-3f external_ids
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:57 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND=/usr/bin/quantum-rootwrap /etc/quantum/rootwrap.conf ovs-vsctl --timeout=2 get Interface tapcd9bea2d-69 external_ids
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session opened for user root by (uid=118)
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:57 ihhoss sudo: pam_unix(sudo:session): session closed for user root
Jun 26 18:41:57 ihhoss sudo:  quantum : TTY=unknown ; PWD=/run ; USER=root ; COMMAND ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2013-06-30 18:08:26 -0500

fifieldt gravatar image

Hi,

This command is called by the get_vif_ports() method in agent/linux/ovs_lib.py, which is called in a "for loop" style for all ports by delete_ports() in the same module, and agent/ovs_cleanup_util.py.

So, my guess is that for some reason, neutron is trying to delete ports, or clean them up - and more often than normal. To solve the problem, we need to find out why - the quantum logs probably have more information on what is going on.

edit flag offensive delete link more
1

answered 2013-07-14 11:34:14 -0500

Mike Gallaher gravatar image

I had this problem also. It seems to be caused by the http://www.mirantis.com/blog/a-new-agent-management-approach-in-quantum-for-openstack-grizzly/ (agent status heartbeat) that was added in grizzly.

The implementation in ovs_quantum_agent._report_state is causing many executions of ovs-vsctl (via root-wrapper) on each heartbeat. By default that is every 2 seconds. As a workaround I set in /etc/quantum/quantum.conf

report_interval = 120

I'm not sure if the slower heartbeat will cause problems elsewhere. The problem isn't really that the heartbeat is too frequent, but rather that it does expensive shell execs each time. A better solution might be to have the agent do the expensive calls less often, and cache the results somewhere where _report_state can get it.

edit flag offensive delete link more
0

answered 2014-04-21 06:06:58 -0500

George Shuklin gravatar image

Here solution: https://bugs.launchpad.net/openstack-cisco/+bug/1197428 (https://bugs.launchpad.net/openstack-...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-06-26 18:47:18 -0500

Seen: 922 times

Last updated: Apr 21 '14