Ask Your Question
0

cannot open dashboard web page

asked 2014-03-27 07:35:26 -0500

spark gravatar image

updated 2014-03-27 10:56:35 -0500

jpichon gravatar image

I just setup openstack, when I first time open the dashboard, there was an error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Apache/2.2.15 (CentOS) Server at 192.168.20.229 Port 80

also I find some log in /var/log/httpd/error_log:

[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3] mod_wsgi (pid=3301): Exception occurred processing WSGI script '/usr/share/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi'.
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3] Traceback (most recent call last):
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/lib/python2.6/site-packages/django/core/handlers/wsgi.py", line 219, in __call__
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     self.load_middleware()
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/lib/python2.6/site-packages/django/core/handlers/base.py", line 39, in load_middleware
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     for middleware_path in settings.MIDDLEWARE_CLASSES:
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/lib/python2.6/site-packages/django/utils/functional.py", line 184, in inner
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     self._setup()
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 42, in _setup
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     self._wrapped = Settings(settings_module)
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/lib/python2.6/site-packages/django/conf/__init__.py", line 93, in __init__
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/lib/python2.6/site-packages/django/utils/importlib.py", line 35, in import_module
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     __import__(name)
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 221, in <module>
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]     from local.local_settings import *  # noqa
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]   File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 98
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1.3]      CACHES = {
[Thu Mar 27 20:15:17 2014] [error] [client 172.16.1 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-03-27 10:55:57 -0500

jpichon gravatar image

It looks like there is an indentation error in your local_settings file around 98, perhaps a typo introduced when you updated the CACHES variable. Feel free to update your question with the few lines around line 98 if you're having trouble spotting the issue, and we can help you find it.

edit flag offensive delete link more
0

answered 2014-03-28 02:47:50 -0500

spark gravatar image

think you jpichon, 'CACHES' is indeed the problem, I follow the install guide change /etc/openstack-dashboard/local_settings default CACHES configuration, but it incur error. i change back to : CACHES = { 'default': { 'BACKEND' : 'django.core.cache.backends.locmem.LocMemCache' } } the page now can open, but still has error as follow: Something went wrong! An unexpected error has occurred. Try refreshing the page. If that doesn't help, contact your local administrator.

then i changed ALLOWED_HOSTS, add my controller IP address ALLOWED_HOSTS = ['localhost', '192.168.20.229'] now everything work normally, i can login dashboard

edit flag offensive delete link more

Comments

Glad it's resolved!

jpichon gravatar imagejpichon ( 2014-03-31 07:11:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-27 07:35:26 -0500

Seen: 1,488 times

Last updated: Mar 28 '14