Ask Your Question
1

Neutron allinone external net problem after reboot

asked 2014-03-27 06:55:33 -0500

dubi gravatar image

updated 2014-03-27 16:33:54 -0500

smaffulli gravatar image

setup : Havana allinone on fedora 19 'yum update' done before the Openstack install but the kernel used when openstack installed is the one that comes with fedora 19 !( 3.9.5-301.fc19.x86_64) I do not reboot after Openstack install is complete and it still works fine

The install generates internal net and external net connetced to each other by a router . The router has 2 ports/interfaces: one connected to the intenal (private) net. The other connected to a gateway in the external net . I generate a VM with attached floating IP

If I enable linux proxy_arp at the single host (allinone) for the floating IP of the VM (ip forwarding is enabled anyhow) I can ping /ssh from the external net to the VM . without this arp_proxy enabled no external ping/ssh works.

In the Linux network I see a br-ext interface generated at install time .It gets an IP from the floating IP pool (first available IP there. The VM gets the next IP). Also as expected the 'netns exec qrouter-xxxx ifconfig' shows the 2 connections of the router to the external gateway and to the private net as follows:

qg-bf1ab041-08: flags=67<up,broadcast,running> mtu 1500

    inet 9.148.26.138  netmask 255.255.255.248  broadcast 9.148.26.143
    inet6 fe80::f816:3eff:fe00:6faf  prefixlen 64  scopeid 0x20<link>
    ether fa:16:3e:00:6f:af  txqueuelen 0  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 10  bytes 684 (684.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

qr-20cfe12e-04: flags=67<up,broadcast,running> mtu 1500

    inet 10.0.0.1  netmask 255.255.255.0  broadcast 10.0.0.255
    inet6 fe80::f816:3eff:fec6:1e4  prefixlen 64  scopeid 0x20<link>
    ether fa:16:3e:c6:01:e4  txqueuelen 0  (Ethernet)
    RX packets 5  bytes 378 (378.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 10  bytes 684 (684.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

The Problem:

I then terminate the VM , log out from Openstack and reboot the host. But now br-ext interface comes up WITHOUT its IP, so I cannot ssh anymore to the VM from the external net. The router , after the reboot, still has its 2 connections as above .

If I restart the linux network twice (service network restart) then the br-ext finally regains its IP address but at the same time the router looses its gateway connection to the external net ( qg-bf1ab041-08 above is lost ) and moreover :all the neutron network is down . Neutron cannot be restarted and actually the whole Openstack is not operational . the host has to be rebooted to reactivate Openstack.

So the advice (linux net restart) given in http://openstack.redhat.com/forum/dis... (official RedHat memo) does not work ! . Maybe it was relevant to Quantum

Any idea how to fix the ext ... (more)

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-29 03:34:21 -0500

dubi gravatar image

found a solution :

if one needs a reboot then redo the pakstack reconfiguration after the reboot . This seems to restore the br-ext IP address while NOT disconnecting the router from the extenal net gateway

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-27 06:55:33 -0500

Seen: 470 times

Last updated: Mar 29 '14