Ask Your Question
0

Unable to connect to AMQP server

asked 2014-03-27 05:31:10 -0500

peeyush gravatar image

Hi all,

I have installed openstack using RDO on fedora 19. Now, the system was unused for a few days. When i opened it today, the setup is not working. I mean I can access nova, glance, keystone etc. but I cant launch the instance. Whenever I tried to boot a VM, it gets stuck at build stage. So, I decided to restart nova-compute and scheduler processes (Have worked for me in past) and here is the output I am getting:

2014-03-27 14:48:44.355 ERROR nova.openstack.common.rpc.impl_qpid [req-2d415e36-dd79-4971-838d-5f1b4e32e64c None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 1 seconds 2014-03-27 14:48:45.372 ERROR nova.openstack.common.rpc.impl_qpid [req-2d415e36-dd79-4971-838d-5f1b4e32e64c None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 2 seconds 2014-03-27 14:48:47.376 ERROR nova.openstack.common.rpc.impl_qpid [req-2d415e36-dd79-4971-838d-5f1b4e32e64c None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 4 seconds

Both the processes are giving the same error. Can you please help me solve the error? Plus, the machine might have been rebooted, if that info is useful.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-03-27 07:57:14 -0500

dbaxps gravatar image

First

[root@dfw02 ~(keystone_boris)]$ netstat -lntp | grep qpidd
tcp        0      0 0.0.0.0:5672            0.0.0.0:*               LISTEN      2758/qpidd          
tcp6       0      0 :::5672                 :::*                    LISTEN      2758/qpidd

Then [root@dfw02 ~(keystone_admin)]$ systemctl restart qpidd.service

might be several times every minute or so

These are snapshots from working cluster :

[root@dfw02 nova(keystone_boris)]$ tail -f scheduler.log
2014-03-27 11:03:36.942 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:04:36.997 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:05:37.057 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:06:37.114 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:07:37.163 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:08:37.182 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:09:37.237 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:10:37.291 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 11:11:37.338 1240 ERROR nova.openstack.common.rpc.impl_qpid [req-3731862b-8c51-44e7-8c6b-ab13f9b05c48 None None] Unable to connect to AMQP server: [Errno 111] ECONNREFUSED. Sleeping 60 seconds
2014-03-27 16:01:19.875 1244 WARNING nova.openstack.common.db.sqlalchemy.session [req-86797513-6a31-4cf0-9d1e-d52aa5c487b5 None None] SQL connection failed. infinite attempts left.

[root@dfw02 nova]# ssh 192.168.1.137
Last login: Thu Mar 27 13:18:03 2014
[root@dfw01 ~]# cd /var/log/nova
[root@dfw01 nova]# tail  -f compute.log
2014-03-27 16:02:00.802 2442 ERROR nova.openstack.common.rpc.impl_qpid [-] Unable to connect to AMQP server: [Errno 110] ETIMEDOUT. Sleeping 4 seconds
2014-03-27 16:02:00.804 2442 ERROR nova.openstack.common.rpc.impl_qpid [-] Unable to connect to AMQP server: [Errno 110] ETIMEDOUT. Sleeping 4 seconds
2014-03-27 16:02:00.805 2442 ERROR nova.openstack.common.rpc.impl_qpid [-] Unable to connect to AMQP server: [Errno 110] ETIMEDOUT. Sleeping 4 seconds
2014-03-27 16:02:08.224 2442 ERROR nova.openstack.common.rpc.impl_qpid [-] Unable to connect to AMQP server: [Errno 110] ETIMEDOUT. Sleeping 1 seconds
2014-03-27 16:02:08.323 2442 WARNING nova.openstack.common.loopingcall [-] task run outlasted interval by 128.506132 sec
2014-03-27 16:03:49.126 2442 WARNING nova.compute.manager [-] Found 4 in the database and 0 on the hypervisor.
2014-03-27 16:13:50.435 2442 WARNING nova.compute.manager ...
(more)
edit flag offensive delete link more

Comments

I had this similar issue and turned out to be an iptables issue. I was installing Icehouse with Neutron networking on 3 VMware VM's using Centos 6.5. The port for qpidd was blocked on the controller node. In general the documentation sho

I recommend iptables adjustments as follows:

-A INPUT -m state --state NEW -m tcp -p tcp --dport 5000 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 5672 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 6080 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 8774 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 9292 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 9696 -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 35357 -j ACCEPT

There may ...(more)

wmrsears@gmail.com gravatar imagewmrsears@gmail.com ( 2014-05-22 11:18:39 -0500 )edit
1

answered 2015-01-16 21:53:00 -0500

Wang Xiaoyu gravatar image

I think that there are some aspects to cause this issue.

  1. Please check iptables, Make sure you iptables settings is right for you.

  2. Check you nova configure file. Is rabbitmq address right? And, the rabbitmq address is putted on [DEFAULT] , check it.

Good luck.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-27 05:31:10 -0500

Seen: 5,497 times

Last updated: Mar 27 '14