Devstack cinder cannot attach volume - Fails Silently

asked 2014-03-27 00:00:03 -0500

Abhay Pai gravatar image

updated 2014-03-27 16:45:11 -0500

smaffulli gravatar image

I am trying to install Cloud Foundry which has a prerequisite that Openstack should be able to attach volumes to the running instances. I have installed openstack with the help of devstack and I have configured it properly so that the VM's can ping each other and also Cinder can create volumes greater that 70Gigs. After searching on the internet, I found out this bug report

Bug 1039826

And by scanning through the answers I think this link would be helpful. I am a noob in applying bug patches. Can anybody please help me solve this issue either by giving a proper solution or by giving a method to apply the patch given in the link above ?

edit retag flag offensive close merge delete

Comments

I don't understand what your problem is. If you're running devstack, that bug has already been fixed in the system you're running so there is no need to patch anything. Edit your question to clearly state the problem you have.

smaffulli gravatar imagesmaffulli ( 2014-03-27 16:46:21 -0500 )edit

I know that the bug has been fixed. But still I am facing problem. Maybe git has cloned the old cinder repo. I am not sure of it. But I am facing the exact same problem. Any idea how to fix this ? I re-installed the Ubuntu server twice and also re-installed Openstack using devstack the same amount of time. Still I am facing the same error.

Abhay Pai gravatar imageAbhay Pai ( 2014-04-02 02:47:15 -0500 )edit

Just erase the repositories that are downloaded and try a fresh devstack install (or set the RECLONE=yes in your local.conf file), unstack, reboot and restack, you should be done ...

Alok Shrivastwa gravatar imageAlok Shrivastwa ( 2016-10-24 01:29:34 -0500 )edit