Ask Your Question
0

Grizzly glance authentication fails

asked 2013-06-26 09:44:41 -0500

raghavendra gravatar image

Unable to communicate with identity service: {"error": {"message": "Invalid project", " code": 401, "title": "Not Authorized"}}. (HTTP 401)

I can wget however cannot save the image and I get the above error. I guess the keystone script may not be correctly aligned or has errors. I have followed the below link http://docs.openstack.org/grizzly/basic-install/apt/openstack-basic-install-apt-grizzly.pdf

Any help would be greatly appreciated?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2013-07-22 21:59:02 -0500

ikhan gravatar image

updated 2013-07-22 22:01:18 -0500

Check if identity for glance was created under keystone and appropriate credentials were entered in glance-api.conf and glance-registry.conf:

admin_tenant_name=
admin_user=
admin_password=

Make sure glance-api-paste.ini & glance-registry-paste.ini has following entry:

[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
delay_auth_decision = true

Make sure glance-registry-paste.ini has following entry:

[pipeline:glance-registry-keystone]
pipeline = authtoken context registryapp

Restart both glance-api & glance-registry services. Now you should be able to access glance service from horizon.

edit flag offensive delete link more

Comments

Thank you. I would surely check.

raghavendra gravatar imageraghavendra ( 2013-07-24 00:40:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-26 09:44:41 -0500

Seen: 420 times

Last updated: Jul 22 '13