HA: neutron-server not able to connect with virtualIP [closed]

asked 2014-03-26 03:53:29 -0500

admin gravatar image

updated 2014-04-07 00:35:39 -0500

HA setup with mysql and galera

LB1: 192.168.2.139

Controller1: 192.168.2.151

Controller2: 192.168.2.152

Controller3: 192.168.2.153

VirtualIP: 192.168.2.221

On Controller1 or on Controller2 , when i am starting neutron-server it is stopping automatically. In log, i am getting error:

TRACE neutron OperationalError: (OperationalError) (2013, "Lost connection to MySQL server at 'reading initial communication packet', system error: 0") None None

On LB, when i am executing, mysql -u root -ppassword -h 192.168.2.151 it is working fine but when i am connecting with virtual Ip i.e.mysql -u root -ppassword -h 192.168.2.221

ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

and output of telnet 192.168.2.221 3306 is

Trying 192.168.2.221...
Connected to 192.168.2.221.
Escape character is '^]'.
Connection closed by foreign host.

mysql-galera is working properly on control01 and control02 i.e. database are syncing between control01 and control02

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by smaffulli
close date 2014-04-18 10:25:57.565720

Comments

which lb (type) you are using ?

foexle ( 2014-04-07 02:24:28 -0500 )edit

@admin I am assuming you are using HAproxy from your previous comment to me. Can you please post your HAproxy and my.cnf config?

SamYaple ( 2014-04-07 08:16:40 -0500 )edit