Ask Your Question
0

In devstack install, n-cpu is prompting for password. What is the password or configuration that I'm missing?

asked 2014-03-25 17:18:41 -0600

Angela gravatar image

updated 2014-03-28 16:18:49 -0600

smaffulli gravatar image

I've installed devstack with neutron services enabled. In screen for n-cpu, it's prompting for password. Instance creation fails, I believe due to n-cpu not being started because of this password prompt. What is the password, or what configuration do I need to add to local.conf to enable n-cpu to start?

Screen output:

stack@ubuntu1204-51-105:~/devstack$ cd /opt/stack/nova && sg libvirtd '/usr/local/bin/nova-compute --config-file /etc/nova/nova.conf' & echo $! >/opt/stack/status/stack/n-cpu.pid; fg || echo "n-cpu failed to start" | tee "/opt/stack/status/stack/n-cpu.failure"
[1] 1730
cd /opt/stack/nova && sg libvirtd '/usr/local/bin/nova-compute --config-file /etc/nova/nova.conf'
Password:
edit retag flag offensive close merge delete

Comments

Looks like something has gone wrong with the install. I'd recommend re-installing.

fifieldt gravatar imagefifieldt ( 2014-04-01 23:37:41 -0600 )edit

I've tried this several times, hoping that cleanup missed something. Uninstall/reinstall is not fixing the issue.

Angela gravatar imageAngela ( 2014-04-07 16:13:54 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-05-01 17:11:42 -0600

mikaelhg gravatar image

Had the same problem, solution was to re-add the user to the libvirtd group in /etc/group.

edit flag offensive delete link more

Comments

Do this by entering sudo usermod -a -G libvirtd <your username>

d3an-meehan gravatar imaged3an-meehan ( 2015-10-22 10:07:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-25 17:18:41 -0600

Seen: 883 times

Last updated: May 01 '14