Ask Your Question
0

ERROR: cliff.app Bad Gateway (HTTP 502) while install

asked 2014-03-23 20:30:42 -0500

plonker gravatar image

Hello, I am new to openstack and using devstack for install and gettiing the follwing error during the install on mint 13. I am using a proxy server for internet connection and localhost is omitted from proxy. Could anyone help me here ?

++ openstack role create admin ERROR: cliff.app Bad Gateway (HTTP 502) + ADMIN_ROLE= + openstack role add --project --user usage: openstack role add [-h] [-f {shell,table}] [-c COLUMN] [--variable VARIABLE] [--prefix PREFIX] --project <project> --user <user> <role> openstack role add: error: argument --project: expected one argument + exit_trap + local r=2 ++ jobs -p + jobs= + [[ -n '' ]]

user@server ~/devstack $ set | grep proxy http_proxy=http://proxy.xx.xxx.com:80/ https_proxy=http://proxy.xxx.xxx.com:80/ no_proxy=localhost,127.0.0.1

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-04-04 09:08:42 -0500

I ran into the same error. My problem was that I had http_proxy and https_proxy defined, but I was missing the no_proxy variable.

See if the following fixes it for you (it worked for me):

hostname% cd ~/devstack

hostname% export http://no_proxy=localhost,127.0.0.1,hostname,hostname.%3Cyourdomainname%3E.com (no_proxy=localhost,127.0.0.1,hostname...)

hostname% sudo rm -rf /opt/stack

hostname% ./unstack.sh

hostname% ./stack.sh

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-23 20:30:42 -0500

Seen: 1,035 times

Last updated: Apr 04 '14