Ask Your Question
1

Not able to set cpuset attribute.

asked 2013-06-26 01:34:41 -0500

Peeyush gravatar image

updated 2013-06-28 10:27:04 -0500

smaffulli gravatar image

In relation to this patch, I have not been able to use it. I mean, as it has been merged so it is there in my code, but I am not sure how to enable it?

As I cant post links, this particular patch adds cpuset attribute to the vcpu element of the instance's xml file. I cant figure out how exactly I can do that for a particular instance. Suppose I want to pin pcpu 2 and 3, so the vcpu entry would be

  <vcpu cpuset="2,3">2</vcpu>

How can I do that?

edit retag flag offensive close merge delete

Comments

The patch seems to have merged https://review.openstack.org/#/c/26363/ so it should be in trunk but I don't know how to use it

smaffulli gravatar imagesmaffulli ( 2013-06-28 10:28:54 -0500 )edit

Yeah, it's there. I can see it. But I cant make it work!

Peeyush gravatar imagePeeyush ( 2013-06-28 11:19:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-06-30 18:22:47 -0500

fifieldt gravatar image

The nova.conf option is called 'vcpu_pin_set', with default=None,

helptext: Which pcpus can be used by vcpus of instance 'e.g: "4-12,^8,15"'),

The blueprint is: https://blueprints.launchpad.net/nova/+spec/auto-cpu-pinning

and describes that this is automatic pinning - not user controlled.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-06-26 01:34:41 -0500

Seen: 508 times

Last updated: Jun 30 '13