Ask Your Question
0

caught error: Timeout while waiting on RPC response - topic: "network", RPC method: "validate_networks" info: "<unknown>"

asked 2014-03-17 15:06:44 -0600

neteng1 gravatar image

updated 2014-03-19 11:26:35 -0600

I am attempting in installing openstack on three servers:

  1. Controller
  2. Compute
  3. Network

I followed the instructions at http://docs.openstack.org/havana/install-guide/install/apt/content/index.html (http://docs.openstack.org/havana/inst...) . I am using Ubuntu 13.10 on all three servers.

I followed the instructions up to installing the dashboard ( http://docs.openstack.org/havana/install-guide/install/apt/content/install_dashboard.html (http://docs.openstack.org/havana/inst...) ) and am able to get to the dashboard. I used the neutron configuration with openvswitch network instructions as we are interested in implementing that and possibly openflow at some time.

I then set up the memcached as suggested. This part confused me a bit, but if I am reading it correctly there are three options for this. Local, memcached and Redis. I am assuming I need to pick one, so I picked memcached. (Please advise if that is incorrect).

I am now trying to install an instance in the dashboard interface and am getting the following error:

  Error: The server has either erred or is incapable of performing the requested operation. (HTTP 500)

I googled this a bit and found a bunch of references to authentication issues. I re-verified username and passwords with what I put into keystone and am still seeing this issue. I looked at the nova-api.log file and I am getting the following:

2014-03-17 15:50:35.585 2384 ERROR nova.api.openstack [req-1bf10e55-3ff7-4c29-8165-7a6ad2a21c4c bb772ea1a561489fbeb7cb52050679c2 8f2b0c3bbdbb492299508c9ef9d909b3] Caught error: Timeout while waiting on RPC response - topic: "network", RPC method: "validate_networks" info: "<unknown>"
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack Traceback (most recent call last):
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/nova/api/openstack/__init__.py", line 119, in __call__
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack     return req.get_response(self.application)
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1296, in send
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack     application, catch_exc_info=False)
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/request.py", line 1260, in call_application
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack     app_iter = application(self.environ, start_response)
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack     return resp(environ, start_response)
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/keystoneclient/middleware/auth_token.py", line 539, in __call__
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack     return self.app(env, start_response)
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack   File "/usr/lib/python2.7/dist-packages/webob/dec.py", line 144, in __call__
2014-03-17 15:50:35.585 2384 TRACE nova.api.openstack     return resp(environ, start_response)
2014-03-17 15:50 ...
(more)
edit retag flag offensive close merge delete

Comments

Caught error: Timeout while waiting on RPC response - topic: "network", RPC method: "validate_networks" info: "<unknown>" Did you setup nova + neutron to use the correct message queue? Default for ubuntu is usually rabbit, centos/rhel is qpid.

mpetason gravatar imagempetason ( 2014-03-19 09:01:22 -0600 )edit

Thank you for your response. I believe so, but I have edited the original post to include the neutron.conf and nova.conf files from both the controller and the nodes. They have definitions for the rabbit_host, rabbit_password and rabbit_port. In the instructions for installation, it only specified a rabbit_user: in the neutron node. Is that correct? Also, it looks like there is only one user (guest)defined in the rabbit server (controller). Thank you again.

neteng1 gravatar imageneteng1 ( 2014-03-19 11:32:02 -0600 )edit

Are you running neutron-server on the network node and the controller node? It should only be running on the controller node. Uncomment:

#security_group_api=neutron

Make it:

security_group_api=neutron

In both of the nova confs.

mpetason gravatar imagempetason ( 2014-03-19 14:29:42 -0600 )edit

Also, did you tell neutron which rpc_backend to use? Similar to nova. There should be a section for:

rpc_backend =

mpetason gravatar imagempetason ( 2014-03-19 14:32:04 -0600 )edit

You need the keystone information in the nova.conf on the compute node too:

[keystone_authtoken]
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = <removed>

mpetason gravatar imagempetason ( 2014-03-19 14:35:23 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-03-28 10:52:03 -0600

changbl gravatar image

updated 2014-03-28 10:55:23 -0600

I had the same error with Havana. In my experience, controller and compute nodes were not correctly configured with RPC backend (RabbitMQ) and database backend (MySQL). I am pasting an example configure here:

# Messaging
rpc_backend = nova.rpc.impl_kombu
rabbit_host = 10.251.0.1

# Auth
auth_strategy = keystone
[keystone_authtoken]
auth_host = 10.251.0.1
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = password
auth_version = v2.0
signing_dir = /tmp/keystone-signing-nova
edit flag offensive delete link more

Comments

1

Is this the conf for nova or neutron? Because I'm running into the same errors at the moment.

Matteo gravatar imageMatteo ( 2014-04-29 07:46:38 -0600 )edit

Please, is that file either nova or neutron?

tattabbum gravatar imagetattabbum ( 2014-05-22 08:58:25 -0600 )edit

setting rpc_backend = nova.rpc.impl_kombu breaks AMQ connection at my side, it works if set to "rabbit"

alraouf gravatar imagealraouf ( 2014-06-25 12:30:35 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-17 15:06:44 -0600

Seen: 5,054 times

Last updated: Mar 28 '14