Ask Your Question
0

after login to the openstack GUI I get an error

asked 2014-03-17 08:16:42 -0500

reverseeng gravatar image

after a succesful login to the dashboard this is what I get:

Something went wrong!

An unexpected error has occurred. Try refreshing the page. If that doesn't help, contact your local administrator.

How to proceed with such an error message? I checked the httpd logs but nothing particular to find there.

Tnx for all answers

edit retag flag offensive close merge delete

Comments

Or you'd take a look in your webserver logs. But that would take the fun out of it.

mrunge gravatar imagemrunge ( 2014-03-18 02:12:05 -0500 )edit

And I quote "I checked the httpd logs but nothing particular to find there." He said there was nothing there.

SamYaple gravatar imageSamYaple ( 2014-03-18 08:33:06 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-03-17 08:35:44 -0500

SamYaple gravatar image

You should enabled debugging for horizon. You can add DEBUG = True in your /etc/openstack-dashboard/local_settings.py while testing. You will want to disable it when you push it into production though.

Just to be clear, the message "Something went wrong!" is coming from Horizon? Or is it a message from your webbrowser?

edit flag offensive delete link more
0

answered 2014-03-18 09:36:32 -0500

mrunge gravatar image

Ok, it looks like the logging options are not enabled then.

Did it work for you at any time? If yes, then I'd suspect, a service died.

Please check, that services are running. I see often, neutron claims to run, but it just failed. Restarting neutron-server often helps.

If it hasn't worked for you at all, please double check your installation and config. Esp. please take a look at the ALLOWED_HOSTS setting, with should contain the dns name of your dashboard webserver (in best case long and short form). That's a frequent error made.

edit flag offensive delete link more

Comments

Just a note here. The allowed_hosts setting can accept wildcards if you having trouble diagnosing if that's the problem.

Tim gravatar imageTim ( 2014-03-18 22:47:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-17 08:16:42 -0500

Seen: 1,216 times

Last updated: Mar 18 '14