Ask Your Question
0

Need HElp: Ceilometer on Compute node not working: HTTPConnectionPool(host='127.0.0.1', port=8774):

asked 2014-03-17 05:36:23 -0500

Hasina gravatar image

updated 2014-04-18 09:47:32 -0500

smaffulli gravatar image

My nova.conf file in compute node:

[DEFAULT]
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lib/nova/tmp
verbose=True
api_paste_config=/etc/nova/api-paste.ini
scheduler_driver=nova.scheduler.multi.MultiScheduler
rabbit_host=100.120.0.91
nova_url=http://100.120.0.91:8774/v1.1/
sql_connection=mysql://nova:procurve@100.120.0.91/nova
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
enabled_apis=ec2,osapi_compute,metadata
rpc_backend=nova.rpc.impl_kombu
instance_usage_audit = True
instance_usage_audit_period = hour
notify_on_state_change = vm_and_task_state
notification_driver = nova.openstack.common.notifier.rpc_notifier
notification_driver = ceilometer.compute.nova_notifier

# Auth
use_deprecated_auth=false
auth_strategy=keystone

# Imaging service
glance_api_servers=100.120.0.91:9292
image_service=nova.image.glance.GlanceImageService

# Vnc configuration
novnc_enabled=true
novncproxy_base_url=http://100.120.0.91:6080/vnc_auto.html
novncproxy_port=6080
vncserver_proxyclient_address=127.0.0.1
vncserver_listen=0.0.0.0

# Network settings
network_api_class=nova.network.neutronv2.api.API
neutron_url=http://100.120.0.91:9696
neutron_auth_strategy=keystone
neutron_admin_tenant_name=service
neutron_admin_username=neutron
neutron_admin_password=procurve
neutron_admin_auth_url=http://100.120.0.91:35357/v2.0
libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtHybridOVSBridgeDriver
#libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtOpenVswitchDriver
#linuxnet_interface_driver=nova.network.linux_net.LinuxOVSInterfaceDriver
#If you want Quantum + Nova Security groups
firewall_driver=nova.virt.firewall.NoopFirewallDriver
security_group_api=neutron
#If you want Nova Security groups only, comment the two lines above and uncomment line -1-.
#firewall_driver=nova.virt.libvirt.firewall.IptablesFirewallDriver

#Metadata
service_quantum_metadata_proxy = True
quantum_metadata_proxy_shared_secret = helloOpenStack

# Compute #
libvirt_type=kvm
compute_driver=libvirt.LibvirtDriver

# Cinder #
volume_api_class=nova.volume.cinder.API
osapi_volume_listen_port=5900

/etc/ceilometer/ceilometer.conf file  on compute node:-
-----------------------------------------------------------------
You must set the secret key that you defined previously. The Telemetry service nodes share this key as a shared secret:

Edit the /etc/ceilometer/ceilometer.conf file and change these lines in the [DEFAULT] section. Replace ADMIN_TOKEN with the admin token that you created previously:

Select Text
1
2
3
4
5
...
[publisher_rpc]
# Secret value for signing metering messages (string value)
metering_secret = <token is been given same as on controller node ceilometer.conf file>
...
Configure the RabbitMQ access:

Edit the /etc/ceilometer/ceilometer.conf file and update the [DEFAULT] section:

Select Text
1
2
3
[DEFAULT]
rabbit_host = 100.120.0.91
rabbit_password = guest
Add the Identity service credentials:

Edit the /etc/ceilometer/ceilometer.conf file and change the [keystone_authtoken] section:

Select Text
1
2
3
4
5
6
7
[keystone_authtoken]
auth_host = 100.120.0.91
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = ceilometer
admin_password = procurve
Also set the [service_credentials] section:

Select Text
1
2
3
4
5
[service_credentials]
os_auth_url = http://100.120.0.91:5000/v2.0
os_username = ceilometer
os_tenant_name = service
os_password = procurve
Configure the log directory.

Edit the /etc/ceilometer/ceilometer.conf file and update the [DEFAULT] section:

Select Text
1
2
[DEFAULT]
log_dir = /var/log/ceilometer
Restart the service with its new settings:

Additional information on controller node-

root@ubuntu-OSC:~# keystone endpoint-list
     +----------------------------------+-----------+----------------------------------------+----------------------------------------+----------------------------------------+----------------------------------+
|                id                |   region  |               publicurl                |              internalurl               |                adminurl                |            service_id            |
+----------------------------------+-----------+----------------------------------------+----------------------------------------+----------------------------------------+----------------------------------+
| 205e67f970b24794abcc583bf36f8505 | RegionOne | http://127.0.0.1:8774/v2/$(tenant_id)s | http://127.0.0.1:8774/v2/$(tenant_id)s | http://127.0.0.1:8774/v2/$(tenant_id)s | d9c3c7b005f94ab88085882aab09d606 |
| 3d82c44b566640f2979d55ca8086273b | regionOne |         http://127.0.0.1 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Please spend some time formatting the question and make the question more clear. Highlight the steps you took to debug the issue, too.

smaffulli gravatar imagesmaffulli ( 2014-03-18 11:56:55 -0500 )edit

If you setup "rabbit_password=guest" because you changed the default password for rabbit, or set it up to use one, then you will need to add the "rabbit_password=guest" to the nova.conf. << that might be it, but you should probably add more log output with the errors as well.

mpetason gravatar imagempetason ( 2014-03-19 06:09:34 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-03-20 04:18:56 -0500

mpetason gravatar image

Your ceilometer endpoint is in a different region. It should match the same region as the others. It's case sensitive. Your end points should be setup on 100.120.0.91, not 127.0.0.1. They need to be accessible on other systems.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-17 05:36:23 -0500

Seen: 821 times

Last updated: Apr 18 '14