Cannot access instances from external network [closed]

asked 2014-03-14 22:21:22 -0500

yencarnacion gravatar image

Hello,

After installing Havana all in one, I followed the instructions at http://openstack.redhat.com/Neutron_with_existing_external_network (http://openstack.redhat.com/Neutron_w...)

My /etc/sysconfig/network-scripts/ifcfg-br-ex looks as follows:

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=192.168.2.200
NETMASK=255.255.255.0
GATEWAY=192.168.2.1
DNS1=192.168.2.1
ONBOOT=yes

My /etc/sysconfig/network-scripts/ifcfg-eth0 looks as follows:

DEVICE=eth0
HWADDR=00:1E:C9:AB:50:8B
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

I added to the /etc/neutron/plugin.ini file these lines:

network_vlan_ranges = physnet1
bridge_mappings = physnet1:br-ex

Then, following the posts on http://openstack.redhat.com/forum/discussion/780/confused-with-neutron-and-external-network-access (http://openstack.redhat.com/forum/dis...) and the video at http://www.youtube.com/watch?v=afImoFeuDnY#t=1104 (http://www.youtube.com/watch?v=afImoF...)

  1. I deleted nets, subnets, ports, routers using the neutron cli, and

  2. I did

    neutron router-create router1
    neutron net-create private
    neutron subnet-create private 10.0.0.0/24 --name private_subnet
    neutron router-interface-add router1 private_subnet
    neutron net-create public --router:external=True
    neutron subnet-create public 192.168.2.0/24 --name public_subnet --enable_dhcp=False --allocation-pool start=192.168.2.224,end=192.168.2.250 --gateway=192.168.2.1
    neutron router-gateway-set router1 public

After setting the router gateway I can ping 192.168.2.224 but under the dashboard network topology I see

192.168.2.224       router_gateway  DOWN

I can assign instances to the public network and they boot, but I cannot connect to them from the external network. I can see the following in the boot log:

Cloud-init v. 0.7.3 running 'init-local' at Sat, 15 Mar 2014 02:56:07 +0000. Up 8.10 seconds.
cloud-init-nonet[9.06]: waiting 10 seconds for network device
cloud-init-nonet[19.08]: waiting 120 seconds for network device

Help would be appreciated.

Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by larsks
close date 2014-03-31 13:50:46.669994

Comments

Boot the instances to the private network and use floating ips.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-03-15 04:44:35 -0500 )edit

Once I added the floating ips as suggested it worked. I was just assuming it would not work because of 192.168.2.224 router_gateway DOWN. Thank you

yencarnacion gravatar imageyencarnacion ( 2014-03-15 04:52:49 -0500 )edit