Ask Your Question
1

ceilometer api put alarm does not trigger heat autoscaling

asked 2014-03-14 10:35:01 -0500

anonymous user

Anonymous

I am using a devstack setup (stable/havana) with heat and ceilometer enabled. I defined a simple threshold alarm in a heat template which works fine: threshold is calculated based on the samples, and if necessary autoscaling is performed accordingly.

Now, I would also like to be able to trigger the alarm&autoscaling by using the ceilometer API, but:

After a call to change the alarm state ( PUT /v2/alarms/(alarm_id)/state ), the alarm state is set to 'alarm' in mongodb. The ceilometer-alarm-evaluator does not, however, register this change to trigger the alarm policy in heat. Any idea why not? Instead, as soon as the next evaluation cycle hits, the state is set back to 'insufficient data'.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-03-16 22:42:50 -0500

ZhiQiang Fan gravatar image

not only PUT /v2/alarms/(alarm_id)/state cannot, neither PUT /v2/alarms/(alarm_id), nor POST /v2/alarms

this is because api only communicates with db, and ceilometer-alarm-evaluator has its own cycle to evluate alarms' state according to the rule and data stored in database(although ceilometer-alarm-evaluator may set current alarm state according to previous alarm state under some condition), the actions will only be triggered in that timepoint of the cycle

edit flag offensive delete link more
0

answered 2014-03-17 05:20:19 -0500

lvh gravatar image

updated 2014-03-18 09:51:23 -0500

Thanks for your reply.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-14 10:35:01 -0500

Seen: 701 times

Last updated: Mar 18 '14