Ask Your Question
1

Issue with ceilometer authentication

asked 2014-03-14 10:29:02 -0600

anonymous user

Anonymous

updated 2014-06-16 14:45:33 -0600

smaffulli gravatar image

I have configured the ceilometer configuration on controller as per the below document. I tried to restart the services but the ceilometer-api service is in stopped state as user is not getting authenticated with keystone.

Configured the mongodb with the ceilometer database.I tried creating service endpoints for the Ceilometer. Unfortunately I am still facing the issue. Would request if anyone can help me to unblock this issue. It would be really helpful.

http://docs.openstack.org/havana/inst...

I configured the auth_host providing both 127.0.0.1 as well as ip address of the controller.

root@ubuntu-OSC:~# ceilometer meter-list
Error communicating with http://100.120.0.91:8777 [Errno 111] Connection refused

Error message seeing on ceilometer-api.log:-

Log error message:-

2014-03-13 08:10:49.223 25493 INFO keystoneclient.middleware.auth_token [-] Starting keystone auth_token middleware
2014-03-13 08:10:49.224 25493 INFO keystoneclient.middleware.auth_token [-] Using /tmp/keystone-signing-xXgcWq as cache directory for signing certificate
2014-03-13 08:10:49.264 25493 CRITICAL ceilometer [-] command SON([('authenticate', 1), ('user', u'ceilometer'), ('nonce', u'a8ae3d14dd4e26d6'), ('key', u'672175228da91fc0867bbc3877456ebc')]) failed: auth fails

root@ubuntu-OSC:~# mongo --host 100.120.0.91
MongoDB shell version: 2.4.6
connecting to: 100.120.0.91:27017/test
>
>
>
> show databases;
local   0.078125GB
test    (empty)
>

>
>
> db.addUser( { user: "ceilometer",
...               pwd: "procurve",
...               roles: [ "readWrite", "dbAdmin" ]
...             } )
{
        "user" : "ceilometer",
        "pwd" : "f3d467485108a73402451b348a1ae854",
        "roles" : [
                "readWrite",
                "dbAdmin"
        ],
        "_id" : ObjectId("53220e347af4a99b142f78b5")
}

Please let me know how to overcome this issue. in /etc/hosts/ i have 127.0.0.1 localhost and 100.120.0.91 ubuntu-OSK as my hostnames.

root@ubuntu-OSC:~# keystone endpoint-list
+----------------------------------+-----------+----------------------------------------+----------------------------------------+----------------------------------------+----------------------------------+
|                id                |   region  |               publicurl                |              internalurl               |                adminurl                |            service_id            |
+----------------------------------+-----------+----------------------------------------+----------------------------------------+----------------------------------------+----------------------------------+
| 205e67f970b24794abcc583bf36f8505 | RegionOne | http://127.0.0.1:8774/v2/$(tenant_id)s | http://127.0.0.1:8774/v2/$(tenant_id)s | http://127.0.0.1:8774/v2/$(tenant_id)s | d9c3c7b005f94ab88085882aab09d606 |
| 3ed9eb95349146469be8ffc78e469d49 | RegionOne |         http://127.0.0.1:9292/         |         http://127.0.0.1:9292/         |         http://127.0.0.1:9292/         | 236d4824a70b4fe1a05d5572917f1258 |
| 586e164bbf0f46f0b4bc497643c25afb | RegionOne |  http://127.0.0.1:8773/services/Cloud  |  http://127.0.0.1:8773/services/Cloud  |  http://127.0.0.1:8773/services/Admin  | beb05b627f514126909f83a535506c44 |
| 9387a0400317494583b4473c621fd301 | RegionOne |       http://127.0.0.1:5000/v2.0       |       http://127.0.0.1:5000/v2.0       |      http://127.0.0.1:35357/v2.0       | 45dd4baabd5b49a6add05b462bc81b44 |
| cad49a6466464c42a498bca295beddc3 | RegionOne | http://127.0.0.1:8776/v1/$(tenant_id)s | http://127.0.0.1:8776/v1/$(tenant_id)s | http://127.0.0.1:8776/v1/$(tenant_id)s | 46f5d4c1d72f4243a6741acb299b6770 |
| ce1d59faa015437d881a1fd2e4bf0bdc | regionOne |        http://:8777        |        http://100.120.0.91:8777        |        http://100.120.0.91:8777        | 9ee294aed3ab4791bbf45ea6eec4772f |
| e661acb362ad4231aa4f42d390538af7 | RegionOne |         http://127.0.0.1:9696/         |         http://127.0.0.1:9696/         |         http://127.0.0.1:9696/         | d69a6e2e977248d4852a3ba2cc7ded40 |
+----------------------------------+-----------+----------------------------------------+----------------------------------------+----------------------------------------+----------------------------------+

root@ubuntu-OSC:~# keystone service-list
+----------------------------------+------------+----------+------------------------------+
|                id                |    name    |   type   |         description          |
+----------------------------------+------------+----------+------------------------------+
| 9ee294aed3ab4791bbf45ea6eec4772f | ceilometer | metering | Ceilometer Telemetry Service |
| 46f5d4c1d72f4243a6741acb299b6770 |   cinder   |  volume  |   OpenStack Volume Service   |
| beb05b627f514126909f83a535506c44 |    ec2     |   ec2    |    OpenStack EC2 service     |
| 236d4824a70b4fe1a05d5572917f1258 |   glance   |  image   |   OpenStack Image Service    |
| 45dd4baabd5b49a6add05b462bc81b44 |  keystone  | identity |      OpenStack Identity      |
| d69a6e2e977248d4852a3ba2cc7ded40 |  neutron   | network  | OpenStack Networking service |
| d9c3c7b005f94ab88085882aab09d606 |    nova    | compute  |  OpenStack Compute Service   |
+----------------------------------+------------+----------+------------------------------+

ceilometer.conf file :

[DEFAULT]

#
# Options defined in ceilometer.middleware
#

# Exchanges name to ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-03-17 05:32:28 -0600

Hasina gravatar image

The issue is resolved after i created the mongo db with 127.0.0.1 and also replacing all the ip address wtih 127.0.0.1 in ceilometer.conf file. and created the service end points with 127.0.0.1 it worked. thanks for the reply.

edit flag offensive delete link more
0

answered 2015-07-10 01:13:38 -0600

I also got similar issue

2015-07-09 21:50:51.644 7518 INFO ceilometer.api.app [-] Full WSGI config used: /etc/ceilometer/api_paste.ini 2015-07-09 21:50:53.843 7518 INFO ceilometer.storage.mongo.utils [-] Connecting to mongodb on [('blrtest37.idc.oracle.com', 27017)] 2015-07-09 21:50:54.428 7518 CRITICAL ceilometer [-] ConfigurationError: command SON([('authenticate', 1), ('user', u'ceilometer'), ('nonce', u'61891572322abdb4'), ('key', u'b74bbb3079dbcb71bb22d4f142b45905')]) failed: auth failed 2015-07-09 21:50:54.428 7518 TRACE ceilometer Traceback (most recent call last): 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/bin/ceilometer-api", line 10, in <module> 2015-07-09 21:50:54.428 7518 TRACE ceilometer sys.exit(main()) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/ceilometer/cmd/api.py", line 23, in main 2015-07-09 21:50:54.428 7518 TRACE ceilometer srv = app.build_server() 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/ceilometer/api/app.py", line 157, in build_server 2015-07-09 21:50:54.428 7518 TRACE ceilometer app = load_app() 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/ceilometer/api/app.py", line 153, in load_app 2015-07-09 21:50:54.428 7518 TRACE ceilometer return deploy.loadapp("config:" + cfg_file) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp 2015-07-09 21:50:54.428 7518 TRACE ceilometer return loadobj(APP, uri, name=name, *kw) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 272, in loadobj 2015-07-09 21:50:54.428 7518 TRACE ceilometer return context.create() 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create 2015-07-09 21:50:54.428 7518 TRACE ceilometer return self.object_type.invoke(self) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 203, in invoke 2015-07-09 21:50:54.428 7518 TRACE ceilometer app = context.app_context.create() 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create 2015-07-09 21:50:54.428 7518 TRACE ceilometer return self.object_type.invoke(self) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 146, in invoke 2015-07-09 21:50:54.428 7518 TRACE ceilometer return fix_call(context.object, context.global_conf, *context.local_conf) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 56, in fix_call 2015-07-09 21:50:54.428 7518 TRACE ceilometer val = callable(args, *kw) 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages/ceilometer/api/app.py", line 181, in app_factory 2015-07-09 21:50:54.428 7518 TRACE ceilometer return VersionSelectorApplication() 2015-07-09 21:50:54.428 7518 TRACE ceilometer File "/usr/lib/python2.7/site-packages ... (more)

edit flag offensive delete link more
0

answered 2014-03-14 15:54:36 -0600

You don't have ceilometer database. You only have test and local database.  Create cieliometer database and then add user to that database.

Did you do step 5 in the instruction that you have linked?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-14 10:29:02 -0600

Seen: 1,912 times

Last updated: Jul 10 '15