Ask Your Question
2

Slow network speed between VM and external

asked 2014-03-14 07:05:41 -0500

Keksior gravatar image

updated 2014-03-18 04:48:18 -0500

darragh-oreilly gravatar image

I've got controller and network node on the one phisycal machine running ubuntu 12.04 (3.8.0-36-generic). The problem is that the bandwidth from my VM network to outside network is:

[ ID] Interval Transfer Bandwidth
[ 6] 0.0-10.3 sec 46.9 MBytes 38.2 Mbits/sec
[ 4] 0.0-12.5 sec 896 KBytes 586 Kbits/sec
[ 5] local 172.100.0.20 port 5001 connected with 172.100.0.101 port 50791

I'm running neutron with VLAN networking. The speeds between VM's are ok ~450 Mb/s. From VM to qrouter is also slow: [ ID] Interval Transfer Bandwidth
[ 5] 0.0-10.0 sec 218 MBytes 182 Mbits/sec
[ 4] 0.0-10.1 sec 29.9 MBytes 24.9 Mbits/sec

I have disabled gro for my br-ex int eth0 on my network/controller node:

$ ethtool -k eth0
Offload parameters for eth0:
rx-checksumming: on
tx-checksumming: on
scatter-gather: on
tcp-segmentation-offload: on
udp-fragmentation-offload: off
generic-segmentation-offload: on
generic-receive-offload: off
large-receive-offload: off
rx-vlan-offload: on
tx-vlan-offload: on
ntuple-filters: off
receive-hashing: off

Please help me get this working at higher speeds.

edit retag flag offensive close merge delete

Comments

When i disabled rx-checksumming and tx-checksumming the transfers gow higher but not as high as i expected: [ ID] Interval Transfer Bandwidth
[ 4] 0.0-10.0 sec 266 MBytes 222 Mbits/sec
[ 5] 0.0-10.1 sec 27.5 MBytes 22.9 Mbits/sec Please help. I'm trying turning off and on and it won't help. Maybe i need to turn off gro at node interface or something?

Keksior gravatar imageKeksior ( 2014-03-17 06:55:47 -0500 )edit

run tcpdump on the qr-xxxxxxxx-xx interface in the qrouter namespace and check for packets much greater than 1500 bytes, eg >1600. That would suggest offloading is happening somewhere.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-03-17 11:25:39 -0500 )edit

From IRC: found that the machine was rebooted and so GRO was enabled on ethX again. After GRO disabled again, there where no more big packets on ethX or gr-xxxxxxx-xx, but still slow. Tcpdump show retransmissions. Suggested turning off all offloading stuff on ethX - that didn't work either.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-03-18 04:45:17 -0500 )edit

I think this issue is only seen with recent Ubuntu kernels - 3.5 and 3.8. A possible solution is to use the older 3.2 kernel on the node running the L3 agent.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-03-18 05:17:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
4

answered 2014-03-18 17:15:23 -0500

sneezewort gravatar image

I am posting this as a possible answer because I was asking the same question in chat yesterday, and I was asked by Keksior to post if I found an answer. I discoved that if you disable tcp segmentation offload on the VM, then network speed from the VM increases dramaticly.

On the VM run:

sudo ethtool -K eth0 tso off

My results follow from running speedtest from the VM.

With nothing disabled:

Testing download speed........................................
Download: 1.32 Mbit/s
Testing upload speed..................................................
Upload: 0.10 Mbit/s

Awful right?

After the neutron "ethtool --offload eth0 gro off" trick:

Testing download speed........................................
Download: 492.79 Mbit/s
Testing upload speed..................................................
Upload: 0.10 Mbit/s

Getting better...

After running "sudo ethtool -K eth0 tso off" on the VM:

Testing download speed........................................
Download: 489.23 Mbit/s
Testing upload speed..................................................
Upload: 166.39 Mbit/s

Hooray!!! I hope this works for you!

edit flag offensive delete link more

Comments

Works fine!

Bau Mesa gravatar imageBau Mesa ( 2014-09-11 11:24:29 -0500 )edit

worked like a charm according to my VM admin !

Leon gravatar imageLeon ( 2015-02-06 12:26:26 -0500 )edit

Dint work for me.. Any other trick? I am getting around 1Mbps speed for downloads.

AB239 gravatar imageAB239 ( 2017-06-29 04:41:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

4 followers

Stats

Asked: 2014-03-14 07:05:41 -0500

Seen: 10,927 times

Last updated: Mar 18 '14