Ask Your Question
0

ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500)

asked 2014-03-14 03:38:46 -0500

travhoang77 gravatar image

updated 2014-03-14 12:46:50 -0500

smaffulli gravatar image

Hello, This is my first time doing a test install of openstack:havana and I am also stuck on the famous issue:

# nova network-create vmnet --fixed-range-v4=10.0.0.0/24 --bridge-interface=br100 --multi-host=T
The server has either erred or it is incapable of performing the requested operation (HTTP 500)

I am running my controller and compute1 node as guest on VirtuBox on a Windows Host.

My /etc/network/interface configuration on controller is

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address172.16.0.10
netmask 255.255.255.0
gateway 172.16.0.1
dns-nameservers 8.8.8.8

auto eth1
address 10.0.3.10
netmask 255.255.255.0

My /etc/network/interface configuration on compute1 is

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address172.16.0.11
netmask 255.255.255.0
gateway 172.16.0.1
dns-nameservers 8.8.8.8

auto eth1
address 10.0.3.11
netmask 255.255.255.0

I have tried and checked that my rabbit password is correct and configured and that I have restarted all the nova services on the controller.

I am getting CRITICAL nova [-] (OperationalErrror no such table: networks u'SELECT networks.created_at AS networks_created_at........ on my nova-network.log

SO i assume it is a database problem even though i entered in the correct database credentials.

AM i doing something wrong, is there a known solution for this? Should I provide more details and logs? Any help would be returned with much gratitude.

edit retag flag offensive close merge delete

Comments

never seen that particular error before. Make sure that you're connecting to the correct mysql host. Edit the question to specify how you installed havana.

smaffulli gravatar imagesmaffulli ( 2014-03-14 12:48:01 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-05-21 04:48:31 -0500

Venu Murthy gravatar image

Hello we were having a similar issue and solved it by editing the nova.conf.

I suppose that you are not specific about having the firewall enabled at this point in time. If that is the case set

firewall_driver=nova.virt.firewall.NoopFirewallDriver
#security_group_api=neutron

ie. comment out the security_group as it is futile to have it enabled while the firewall itself is off.

Hope this helps!

-Venu

edit flag offensive delete link more

Comments

The error message he was seeing had to do with database tables being created. The db sync added all of the tables needed by nova. The firewall_driver = fixes other issues since it tells nova where to look for security groups.

mpetason gravatar imagempetason ( 2014-05-22 10:38:51 -0500 )edit
3

answered 2014-03-15 07:04:36 -0500

mpetason gravatar image

If you are using nova network then you probably need to run:

Nova-manage db sync

It's that or db_sync. Each service seems to be different.

As long as nova is aware of the type of network you have it should setup the tables in MySQL.

edit flag offensive delete link more

Comments

Hello .. I am getting same error. And didnt find any solution to the problem yet. I tried to run

nova-manage db sync

And then i tried to run nova network-create vmnet --fixed-range-v4=10.0.0.0/24 --bridge-interface=br100 --multi-host=T But still i get same error. Please help me with this problem.

Indeep_Minku-OPENSTACK gravatar imageIndeep_Minku-OPENSTACK ( 2014-04-02 11:33:28 -0500 )edit

Is your nova table created correctly? Because if not the db sync command didn't work. If not look into /var/lib/nova/ and search for the nova.sqlite file. If it is there delete it and use the db sync command again.

Matteo gravatar imageMatteo ( 2014-04-04 04:47:49 -0500 )edit
0

answered 2018-05-01 15:38:30 -0500

Titoss gravatar image

I had the same issue when executing "openstack compute service list", but when I executed "nova-status upgrade check" an error showed saying that connection failed on controller:35357, when I checked my Keystone endpoints I didn't find any one with that url so I tried to change the auth_url in [keystone_authtoken] at /etc/nova/nova.conf to the following : auth_url = http://controller:5000/v3. And when I executed both of the previous commands it actually worked!!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-14 03:38:46 -0500

Seen: 17,906 times

Last updated: May 01