Ask Your Question
2

devstack on 13.10 upgraded from 12.10, doesnt run ./stack.sh

asked 2014-03-12 13:56:15 -0600

ramprasvm gravatar image

updated 2014-03-13 01:09:47 -0600

Ive installed devstack on Ubuntu 12.10

Ive upgraded Ubuntu 12.10 to 13.10

also checked out the devstack folder from git

when Im running ./stack.sh, Im getting following error:

/devstack$ ./stack.sh 
[Call Trace]
./stack.sh:292:die
[ERROR] ./stack.sh:292 Could not determine host ip address. Either localrc specified dhcp on or defaulted

googled online and suspecting this bug.. Did any of you face this issue??

edit retag flag offensive close merge delete

4 answers

Sort by ยป oldest newest most voted
4

answered 2014-03-13 07:24:16 -0600

If you are in LAN or Wifi, your DHCP server changes your IP once in a while. In your previous stack.sh session, it would have configured by some other IP of yours which got changed after upgrading.

In localrc, set

HOST_IP=127.0.0.1

do ./unstack.sh and then ./stack.sh, after this your localhost interface will be serving all your purposes.

Hope this helps.

edit flag offensive delete link more

Comments

can you please tell me where would be "localrc" is it in devstack folder?? Im not able to find one :(

ramprasvm gravatar imageramprasvm ( 2014-03-13 13:03:11 -0600 )edit

I think you should see local.conf otherwise

prasoontelang gravatar imageprasoontelang ( 2014-03-14 01:30:48 -0600 )edit
2

answered 2016-12-17 02:33:25 -0600

after cloning devstack branch, create local.conf as below

[[local|localrc]] HOST_IP=127.0.0.1 ADMIN_PASSWORD=admin DATABASE_PASSWORD=$ADMIN_PASSWORD RABBIT_PASSWORD=$ADMIN_PASSWORD SERVICE_PASSWORD=$ADMIN_PASSWORD

and run ./stack/sh

edit flag offensive delete link more
2

answered 2014-03-14 05:15:45 -0600

harikrishna-mallavolu gravatar image

When you clone the devstack base you won't get any localrc file.You atleast need to minimum configuration in order to run stack.sh. Follow the instructions in the follwoing link.

http://devstack.org/configuration.html
edit flag offensive delete link more

Comments

thank you.. it worked out.. same thing mentioned in configuration doc as what is mentioned by prasoontelang..

ramprasvm gravatar imageramprasvm ( 2014-03-20 14:32:10 -0600 )edit
1

answered 2016-09-17 01:21:56 -0600

mattheal gravatar image

I have the same issue but I have the local.conf file already created, the error message is as follows: /home/stack/devstack/stackrc:773:die [ERROR] /home/stack/devstack/stackrc:773 Could not determine host ip address. See local.conf for suggestions on setting HOST_IP.

contents of my devstack directory: ~/devstack$ ls clean.sh files lib README.md tests data functions LICENSE run_tests.sh tools doc functions-common local.conf samples tox.ini exerciserc FUTURE.rst MAINTAINERS.rst setup.cfg unstack.sh exercises gate Makefile setup.py exercise.sh HACKING.rst openrc stackrc extras.d inc pkg stack.sh

*note that local.conf exists in the devstack directory contents of local.conf:

cat local.conf [[local|localrc]] ADMIN_PASSWORD=openstack DATABASE_PASSWORD=openstack RABBIT_PASSWORD=openstack SERVICE_PASSWORD=openstack HOST_IP=10.0.0.77

results of running ifconfig: wlp2s0 Link encap:Ethernet HWaddr dc:53:60:66:ce:93
inet addr:10.0.0.77

As you can see I have the HOST_IP set in local.conf to the ipaddress of my laptop. I have my laptop configured for static IP I'm using the stack user with super user privileges and yet openstack still tells me it can't find my IP address, what's even more frustrating is that during the ./stack.sh running process it tells me this:

+++functions-common:address_in_net:2182 local ip=10.0.0.77

What the hell is going on?

edit flag offensive delete link more

Comments

You are responding to a three, almost four year old post (and so am I:( ). Better create a new post. Please be aware that devstack is not OpenStack, but it's a huge shell script for setting up OpenStack for test purposes.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-17 06:15:48 -0600 )edit

To find out what's going on, enable debug printouts in stackrc and try again. This will help you understand if HOST_IP is set, and if not, why not.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-17 06:16:44 -0600 )edit

I just noticed that your HOST_IP is in the default fixed IP address range. Not sure if that is a problem. You can set it to something else with FIXED_RANGE=10.100.100.0/24, for example.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-17 06:22:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-12 13:56:15 -0600

Seen: 8,833 times

Last updated: Dec 17 '16