Ask Your Question
0

protocol_port value is not an integer

asked 2014-03-12 02:51:35 -0500

RiscYu gravatar image

Hi I want to create a sample autoscaling stack but I always get the following message

{"message": "Property error : ElasticLoadBalancer: protocol_port value is not an integer", "traceback": null, "type": "StackValidationFailed"}

My template about OS::Neutron::LoadBalancer are following:

 ElasticLoadBalancer:
Type: OS::Neutron::LoadBalancer
Properties:
  pool_id: 8d416681-ff99-4698-bfef-a2788ce053d3
  protocol_port: '80'

the total template content is saved at the following address template content

Is there a bug In create OS::Neutron::LoadBalancer ? Or there are something needed to be added in my template?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-23 12:05:17 -0500

zaneb gravatar image

You're passing a string instead of an integer for the protocol_port value. You want:

  protocol_port: 80

not:

  protocol_port: '80'
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-12 02:51:35 -0500

Seen: 52 times

Last updated: Apr 23 '14