Ask Your Question
2

What am I messing up when I try to bring my Neutron l3 agent under Pacemaker?

asked 2014-03-11 17:51:25 -0500

mulligan gravatar image

I have a working, multi-node Openstack Havana setup using a dedicated Neutron node that I am trying to add HA functionality to. However, the following is the status of Pacemaker with respect to the Neutron's L3 agent:

pcs status
Cluster name: pacemaker1
Last updated: Tue Mar 11 15:46:22 2014
Last change: Fri Mar  7 13:22:30 2014 via crmd on 10.1.2.20
Stack: cman
Current DC: 10.1.2.20 - partition with quorum
Version: 1.1.10-14.el6_5.2-368c726
6 Nodes configured
1 Resources configured


Online: [ 10.1.2.20 10.1.2.21 ]
OFFLINE: [ Node3 networker1 networker2 networker3 ]

Full list of resources:

 p_neutron-agent-l3     (ocf::openstack:neutron-agent-l3):      Stopped

Failed actions:
    p_neutron-agent-l3_start_0 on 10.1.2.20 'unknown error' (1): call=8, status=Timed Out, last-rc-change='Fri Mar  7 13:22:52 2014', queued=20001ms, exec=0ms
    p_neutron-agent-l3_start_0 on 10.1.2.21 'unknown error' (1): call=8, status=Timed Out, last-rc-change='Tue Mar 11 15:31:43 2014', queued=20003ms, exec=0ms

and this is logged:

Mar 11 15:31:45 networker3 neutron-agent-l3(p_neutron-agent-l3)[21462]: ERROR: Neutron L3 Server is not connected to the Neutron server: 1
Mar 11 15:31:46 networker3 neutron-agent-l3(p_neutron-agent-l3)[21462]: ERROR: Neutron L3 Server is not connected to the Neutron server: 1
Mar 11 15:31:47 networker3 neutron-agent-l3(p_neutron-agent-l3)[21462]: ERROR: Neutron L3 Server is not connected to the Neutron server: 1
...

Am sure there is an oversight here on my part but I do not yet see how I've bungled the resource agent connection to neutron-l3-agent?

edit retag flag offensive close merge delete

Comments

Hi,

Did your issue got resolved ?

I'm facing exactly same issue, neutron-l3-agent is working fine as standalone

Vikrant Pawar gravatar imageVikrant Pawar ( 2014-04-29 07:40:32 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-09 02:41:50 -0500

zeljko-jagust gravatar image

updated 2014-07-09 05:47:23 -0500

Hello.

You're not messing up anything, it's the neutron-agent-l3 script to blame as it tries to communicate with neutron server directly on port 9696, while communication is handled by AMQP service (RabbitMQ in my case). You need to modify the script to use rabbitmq port and not neutron server one.

Best regards

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-03-11 17:51:25 -0500

Seen: 393 times

Last updated: Jul 09 '14