openvswitch, missing phy-br-eth1 and int-br-eth1

asked 2014-03-10 16:19:50 -0600

mosorio gravatar image

updated 2014-03-10 16:20:17 -0600

According with ( and other posts, I should see the phy-br-eth1 and int-br-eth1 but I don't see the veth pairs when I execute ovs-vsctl show

ovs-vsctl show
    Bridge br-ex
        Port "qg-e0aa8fe0-b0"
            Interface "qg-e0aa8fe0-b0"
                type: internal
        Port "tape0aa8fe0-b0"
            Interface "tape0aa8fe0-b0"
        Port br-ex
            Interface br-ex
                type: internal
    Bridge "br-eth1"
        Port "br-eth1"
            Interface "br-eth1"
                type: internal
        Port "eth1"
            Interface "eth1"
    Bridge br-int
        Port "tapee2d9122-3c"
            Interface "tapee2d9122-3c"
        Port "tapb5a3e1a5-be"
            tag: 1
            Interface "tapb5a3e1a5-be"
                type: internal
        Port br-int
            Interface br-int
                type: internal
        Port "qr-ee2d9122-3c"
            tag: 1
            Interface "qr-ee2d9122-3c"
                type: internal
        Port "tap7b242f7a-6d"
            tag: 2
            Interface "tap7b242f7a-6d"
                type: internal
    ovs_version: "2.0.1"

I'm using - Ubuntu 14.04 - neutron 1:2014.1~b2-0ubuntu6
- opevswitch 2.0.1+git20140120-0ubuntu2 - kernel 3.12.13-031213-generic

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-03-11 11:49:09 -0600

Check your /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini file. It should contain something that looks like this if you are using VLANS:

tenant_network_type = vlan
network_vlan_ranges = physnet1:1:4094
bridge_mappings = physnet1:br-DATA_INTERFACE

Where DATA_INTERFACE is the interface you are connecting to your data network. eth1 in this case. Once that is done, you need to create a bridge for eth1 and add eth1 to this bridge using:

# ovs-vsctl add-br br-DATA_INTERFACE
# ovs-vsctl add-port br-DATA_INTERFACE DATA_INTERFACE

If you are using GRE tunnels, your /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini file should contain:

tenant_network_type = gre
tunnel_id_ranges = 1:1000
enable_tunneling = True
integration_bridge = br-int
tunnel_bridge = br-tun

Here, DATA_INTERFACE_IP is the IP address plumbed on eth1.

Restart the openvswitch-agent once this is done.

#service neutron-openvswitch-agent restart
edit flag offensive delete link more


I already did those steps But i noticed something, I'm running neutron with openvswitch's plugin. But neutron is running with ml2 when i check the process. Is normal? ps aux | grep neutron-server neutron 2043 1.6 1.3 212224 52616 ? Ss Mar12 7:12 /usr/bin/python /usr/bin/neutron-server --config-file /etc/neutron/neutron.conf --log-file /var/log/neutron/server.log --config-file /etc/neutron/plugins/ml2/ml2_conf.ini

mosorio gravatar imagemosorio ( 2014-03-12 22:39:56 -0600 )edit

what does "core_plugin" in /etc/neutron/neutron.conf say? It should point to the OVS plugin in your case, but I suspect it is using the ML2 plugin instead.

mithilarun gravatar imagemithilarun ( 2014-03-13 12:08:43 -0600 )edit

I fixed it. I found a hardcoded path. I think that it's a bug. /etc/default/neutron-server:NEUTRON_PLUGIN_CONFIG="/etc/neutron/plugins/ml2/ml2_conf.ini"

mosorio gravatar imagemosorio ( 2014-03-17 22:41:04 -0600 )edit

This is interesting. It would be good to know why that happened. File a bug on Launchpad with your environment details. Also, if you could share the link here, it would be great. I'm curious :)

mithilarun gravatar imagemithilarun ( 2014-03-18 08:32:55 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-03-10 16:19:50 -0600

Seen: 3,614 times

Last updated: Mar 11 '14